4

I still have the issue with Ubuntu 14.04 as I had on Mint 17.3: My laptop is connected to the TV via HDMI. Everything works fine. If I shut down the computer and plug off the HDMI no sound is coming from the internal speakers for some(?) video files. Sometimes youtube videos are affected too. Other sounds (system notifications, alerts and test sounds) work fine.

Clicking in the sound settings on internal speaker does not help. A reboot does not work either.

The only way to get the sound for the video file is to go back to the TV, plug in the HDMI and then select internal speaker output. Then I can unplug HDMI again.

But what if I don't have a HDMI cable available?

Thanks for your help. (LAPTOP is TUXEDO with Ubuntu 16.04)

  • I don0t understand how you expect the sound to come off after you shut down the computer... With the computer on, did you try to select a different output in Settings>Audio? – dadexix86 Jul 28 '16 at 10:22
  • Sorry - of course I reboot my computer and try to play a video. After that reboot (no matter how many times I rebooted) the output is set to internal speakers. Every sound is sent to the internal speakers correctly, but the video sound. – johkra Jul 28 '16 at 18:10
3

I had the same problem, here is how to allow internal sound after using HDMI output - this worked for me.

In the hidden cache folder in your home directory, there will be a file called something like event-sound-cache.tdb.641c9db826a44f28bb9596d6df3020c2.x86_64-pc-linux-gnu. Just find the file and remove it. Now, your internal sound should work.

In a terminal, from home directory:

cd .cache
ls -a

Now look for the file starting with event-sound-cache.tdb. For me, it was event-sound-cache.tdb.641c9db826a44f28bb9596d6df3020c2.x86_64-pc-linux-gnu

Now, in the terminal, type:

rm <file name here>

For me, my input looked like this:

rm event-sound-cache.tdb.641c9db826a44f28bb9596d6df3020c2.x86_64-pc-linux-gnu

Note that the event-sound-cache.tdb file with be unique to your machine-id and OS.

Your internal sound should now work. If the sound still does not work, go to the sound application and re-select Speakers (Built-in Audio) as the option for sound.

  • did not work for me unfortunately. – vextorspace May 29 '17 at 23:55
  • I tried this solution on Ubuntu 18.04. did not work for me – Raghav Mittal Jun 5 '18 at 10:40
1

I had to find another solution since clear_night_sky's solution didn't work for me.

I went to Settings -> Sound, and switched between the "Input" and "Output" tabs and voilá. Sound was back. Hope that can help someone too.

1

I had the same problem in 18.04, which was kind of annoying, since I had no access to the HDMI Monitor at the time, when I noticed the Problem. So I could not do the reconnect trick.

Restarting PulseAudio worked for me.

pulseaudio -k 

( stops PulseAudio)

pulseaudio -D 

( restarts PulseAudio as daemon, maybe not necessary since PulseAudio restarts itself )

1

I fixed with this

$ rm -rf /tmp/pulse* ~/.pulse* ~/.config/pulse
$ pulseaudio -k
$ pulseaudio --start
-1

If this can help...

I encountered this problem after disconnecting the HDMI cable then letting my PC on stand-by until the battery exhausted.

I tried the above and it did not work. What did is: - I reconnected the TV, - then I had the choice again between the 2 outputs, - selected built-in speakers, - selected built-in monitor display, - Disconnected the HDMI

  • It did it again. This time it was after I properly shut down the computer before disconnecting the HDMI cable from it. Now, and until I reconnect to the TV and select "built-in speakers" as sound output, the sound will not go through built-in speakers despite the fact that it is set this way. Definitely something to improve. Previous versions did not have this issue. – user114242 Sep 25 '18 at 5:38

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.