o.k, this is embarrassing:

I have installed Compiz Config Settings Manager and tried to fix it so that the transition time between changing tabs (using alt+tab) will be short. by accident I un-pressed V from something else, and it asked me about a conflict - I pressed the "x" button to close the window and as a result I stopped seeing the unity interface. That is - I can not see any buttons of the left side.

I went to the terminal (ctrl+alt+F1) and ran


As a result I got the following error:

$ ccsm
/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 93, in <module>
    import ccm
  File "/usr/lib/python2.7/site-packages/ccm/__init__.py", line 1, in <module>
    from ccm.Conflicts import *
  File "/usr/lib/python2.7/site-packages/ccm/Conflicts.py", line 26, in <module>
    from ccm.Constants import *
  File "/usr/lib/python2.7/site-packages/ccm/Constants.py", line 29, in <module>
    CurrentScreenNum = gtk.gdk.display_get_default().get_default_screen().get_number()
AttributeError: 'NoneType' object has no attribute 'get_default_screen'

What should I do next?

  • 1
    have you tried unity --replace and if fails unity --reset? – Stefano Mtangoo Nov 18 '11 at 7:51
  • 1
    When running the unity --replace I get: warning: no display variable set, setting it to :0 unity-panel-service: no process found – Tal Galili Nov 18 '11 at 7:59
  • and now it doesn't respond to any more commands. Can I return to putting commands without restarting? – Tal Galili Nov 18 '11 at 8:01
  • Which version of Ubuntu do you use? I cannot see it in a tag! – Stefano Mtangoo Nov 18 '11 at 8:02
  • there we go ctrl+c ubuntuforums.org/showthread.php?t=1047348 – Tal Galili Nov 18 '11 at 8:02

This seemed fixed once I went to terminal (ctrl+alt+F1) and pressed:

gconftool-2 --recursive-unset /apps/compiz-1
gconftool-2 --recursive-unset /apps/compizconfig-1
rm ~/.compiz-1/session/*
rm ~/.config/compiz-1/compizconfig/config
unity --reset

source: http://ubuntuforums.org/showthread.php?t=1866462

| improve this answer | |
  • Glad that finally you can enjoy your computer! – Stefano Mtangoo Nov 18 '11 at 10:02

You can try to reset unity settings with unity --replace and if fails try unity --reset If all those fails and you still cannot get to CCSM then reinstall it with commands: if you don't want to remove setting substitute purge with remove in command below

sudo apt-get purge compizconfig-settings-manager
sudo apt-get install compizconfig-settings-manager

Disclaimer: Iam not sure the link Iam about to post is still applicable as thread dates to 2008. http://ubuntuforums.org/showthread.php?t=799070

UPDATE It seems as if you are not yet logged in GUI, and so there is no XServer running yet. Try in failsafe mode (recovery mode) and fix things from there

| improve this answer | |
  • ok, I ran both commands (without errors). But the problem stays the same. – Tal Galili Nov 18 '11 at 8:05
  • Hi Stefano - how do I get there? and once there - how do I fix? :) – Tal Galili Nov 18 '11 at 8:07
  • Hi again - I see that my computer freezes when I try to enter to recovery mode. But in any event, it is not clear to me what should be hapanning when I am there vs the simple ctrl+alt+T – Tal Galili Nov 18 '11 at 9:04
  • can you reach tty terminal, I mean that black screen where you can login and type commands? – Stefano Mtangoo Nov 18 '11 at 9:14
  • Hi Stefano - I can reach it without a problem (through ctrl+alt+F1). The problem is that even after running the above code - I am still left with the same issue :( – Tal Galili Nov 18 '11 at 9:16

I had the same problem. The reason was compiz which I removed. Here is my solution:

  1. Make sure that Intel Graphics driver and Nvidia Graphics driver do not conflict in which case you can use:

    sudo apt-get purge nvidia*   

    ...to remove the Nvidia graphics driver.

  2. Make sure you do not remove unity-desktopcompizccsm which you can reinstall by running:

    sudo apt-get purge unity-desktop compiz ccsm  
    sudo apt-get autoremove
    sudo reboot 

    after restart your computer

    sudo apt-get install unity-desktop compiz ccsm 
  3. Clear the old error gnome configure files.

    cd ~  
    ls -all  
    sudo rm -rf .gnome2/ .gnome2_private/ .config/ .gconfd/ .gconf/ .gnome/  
  4. Restart your computer.

    sudo reboot
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.