1

My problem:

I am connected to Ethernet "wired connection 1", I can see that in the network manager (the up and down arrows).

But when i open up Firefox or anything else that requires internet connection I get told the same thing; no internet connection.

Information so far

ifconfig:

kasper@kasper-To-be-filled-by-O-E-M:~$ ifconfig enp3s0 Link encap:Ethernet HWaddr 94:de:80:c7:fd:2b
inet6 addr: fe80::f527:1269:a6f5:57e5/64 Scope:Link inet6 addr: 2001:878:3ac:163:8a7:7349:6e60:d84/64 Scope:Global UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:8 errors:0 dropped:0 overruns:0 frame:0 TX packets:3 errors:0 dropped:47 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:848 (848.0 B) TX bytes:288 (288.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:2292 errors:0 dropped:0 overruns:0 frame:0 TX packets:2292 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1 RX bytes:171576 (171.5 KB) TX bytes:171576 (171.5 KB)

I should note that no other devices have trouble connecting to the router nor does windows 7 when i dual boot to that.

Ubuntu version 16.04

If you need more information, please do tell me.

edit 1

when i do ping google.com i get:

kasper@kasper-To-be-filled-by-O-E-M:~$ ping google.com ping: unknown host google.com

when i do /etc/network/interfaces i get:

kasper@kasper-To-be-filled-by-O-E-M:~$ cat /etc/network/interfaces

interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback auto eth iface eth0 inet dhcp

i hope this help resolve the problem.

0

If enp3s0 is your default interface for Ethernet connection, then we can see that there is no IP assigned to it.

Try the following command:

ping www.google.com

If the pong is successful then there is internet connection. If you find the output as

cannot resolve host

Then you need to check your network configuration page to find whether DHCP and DNS is enabled or not. Can you please provide the output of

/etc/network/interfaces

file. For Ubuntu 16.04 location may vary.

  • the BOLD part of interfaces(5) is because it has a # in front of it. – Kasper Jensen Jul 28 '16 at 18:23
  • Here it is showing the interface as eth0, but your showing the output of eth0. Are you having eth0 interface? – Bidyut Jul 29 '16 at 16:22
  • Try the command ifconfig. From the ping result we can see that you are not having dns-nameserver set. Hence we canmot resolve the host. – Bidyut Jul 29 '16 at 16:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.