0

Before installing Ubuntu 16.04.1, my PC (Acer Aspire XC-603/Aspire XC-603) was set up with a dual boot of Win 8.1 (pre-installed) and Ubuntu 16.04. The dual boot UEFI worked fine as I was able to select either Ubuntu or Win 8.1. After installing Ubuntu 16.04.1, I cannot boot to Win 8.1. The Grub menu is the same as before, but when I select “Windows Boot Manager”, I get the following display:

error message

I have a usb memory stick with the Win 8.1 recovery files, but when I insert the stick and reboot, the computer does not recognize it (even though I have Removable Device as #1 boot priority) and goes right to the Grub menu. Strangely, after booting into Ubuntu 16.04.1, and launching Files, and then inserting the usb Win 8.1 recovery stick, Files will recognize the usb for a very short time, then not show anything in the usb port. However, if I insert the usb Win 8.1 recovery stick for another computer (Lenova), Files will detect it and show it. I don’t know why there is a difference as both sticks were OK before.

Of note during the 16.04.1 install, I selected “Something Else”, and got this display:

Gpartd

Notice the 2 partitions named “unallocated”. These were not present for my previous setup, and the size of sda1 was 600 MiB and the size of sda2 was 300 MiB. All the other partitions shown above matched those of the previous Win 8.1 and Ubuntu 16.04 dual boot setup. I right-clicked each “unallocated” partition, but there were no options to resize. When I right-clicked sda1 or 2, I could resize, and this shrunk the following unallocated partition commensurately. When sda1 size is set at 600 MiB, the following unallocated partition disappears. Likewise for sda2. But when I got the warning that resizing could lose all data, I canceled the change. If I “apply” the resize operation, will the data in sda 1 and 2 be lost? And will the missing “Boot Configuration Data” (mentioned in the first pic) be recovered?

Also during the install I set the “Device for boot loader installation” to /dev/sda ATA……...”. Should I have set it to sda2?

Lastly, in Ubuntu Files I can open the Win 8.1 OS and all the folders and files appear. I did find the file “BCD”, shown in the first pic, at Win\Boot\DVD\EFI\BCD.

What should I try next?

0

Problem solved. First off, I completed the re-size operation described above to eliminate the "unallocated" partitions. I used “Disk” to set the usb sticks to “mount”. I used Ub LiveCD to run “Boot-Repair” summary report with each stick in the port and found that the stick for the Acer pc was bootable, but not the one for the Lenova.
Inserted bootable stick, booted pc, tapping F12 after the beep, and got the boot device menu. I selected the bootable recovrery stick, which brought the blue Win screen to select language. I then selected the “Troubleshoot” icon, then “Advanced opts”, then “Command prompt”. At the prompt I entered “echo list volume | diskpart”. This displayed a table of data for 8 “volumes”; the labels and sizes for Win partitions matched the partitions shown in Gparted. But the Fs for the 300MB (=sda2, efi) partition read RAW instead of FAT32. This had to be reformatted. So files shown in the Boot-Repair summary for sda2 first had to be saved. I used Live CD and “Files” (sda2 mounted) to save to my usb b/u files memory stick. Then I used Win recovery stick again to get to Command prompt and entered, sequentially: diskpart, list disk, select disk # (for sda=0), list volume, select volume # (for sda2), format quick fs=fat32 label=ESP, assign letter=J, exit. Then entered “chkdsk sda2: /F /X”. Result was OK, as it was for the other partitions. Then did “echo list volume | diskpart” again. Sda2 now showed Fs=FAT32, Label=ESP, letter=J. Then – back to Live CD - created the folders in sda2 to match what was on the Boot-Repair report: “sudo mkdir /mnt/EFI” (etc, one step at a time.) Then inserted my usb b/u stick, made sure sda2 was mounted, and used 2 “Files” windows to “copy to” the files from the b/u to the proper sda2 folders. Then inserted Win recovery stick, bootup (tapping F12) --> Troubleshoot window --> Advanced options --> then “Startup Repair”.
Removed recovery stick and re-booted. It went to Win 8.1. I checked the Win Disk Mngmnt, and it did not show any Ubuntu partitions. This was reported on an Ub website as a bug. Later, Gparted showed no changes to the partitions. Also, none of my personal files in either OS were lost.
Booted to pc BIOS and changed boot order to Ub=#1, Win Boot Mgr=#2. Re-booted but the pc did not go to the Ubuntu OS. Instead it displayed the following message: “Welcome to emergency model. After logging in, type “journalctl -xb” to view system logs, “systemctl reboot” to reboot, “systemctl default” or ^D to try again to boot into default mode. Press enter for Maintenance or Cntrl+D to continue”. Below the message was a grub> prompt. Pressed Enter and got same message. Pressed Cntrl+D and got same message. Shutdown and used Live CD to run Boot-Repair “recommended”. Re-booted and got the grub menu – with many more options than before (→ indicates where each lead) Ubuntu → Ubuntu 16.04.1 on hard drive Advanced options → recovery options window Win UEFI bkpbootmgfw.efi → Win 8.1 Win Boot UEFI loader → Win 8.1 EFI/ubuntu/fwupx64.efi → recycles to this list EFI//ubuntu/mokmanager.efi → a blue screen with a menu that recycled to this list and (?) EFI/OEM/Boot/bootmgfw.efi → Win 8.1 Win Boot Mgr (on /dev/sda2) → recycles to this list System setup → BIOS menu. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.