0

I'm developing a webInterface so I installed Opera and Chrome on my KUbuntu 16.04. System (additionally to Firefox which I usually use)

BUT ... It seems that after installing Chrome some services use Chrome es default browser though Firefox IS my default browser!

e.g. If I click on a URL in Thunderbird -> opens in Chrome If I click directly on phpmyadmin from the KStarter -> opens in Chrome

Before installing Chrome everything just opened in Firefox

Any idea how to make Firefox REALLY default browser again?

0

You can use the Settings manager to update the default Web Browser. Take a look on this thread: How to golbally set default web browser, at the end, an user solved this, by chosing the desired web browser on Default Applications -> Web Browser.

To make Mozilla Firefox the default, just type firefox in the input text field.

4
  • Hi, first off all thanks! I did that, and after reboot it still says "firefox" but unfortunatly mentioned apps still open in google-chrome :/ In the moment I'm doing a reinstall of firefox and chrome and try again update-alternatives --config x-www-browser (which before failed for some reason) – derHugo Jul 27 '16 at 16:46
  • Hi, please, leave a comment with the results of this to keep us updated. I hope that work for you, so, many people could solve similar problems with your procedure. Thanks in advance. – GTRONICK Jul 27 '16 at 16:53
  • 1
    So it finally worked: 1. uninstalled (purged) both browsers; 2. installed firefox and made it system-default 3. checked it back with the update-alternatives 4. installed google-chrome 5. tested it with thunderbird and phpmyadmin -> no it works as it's supposed to – derHugo Jul 27 '16 at 17:34
  • Excellent!, have a nice and funny Ubuntu experience. Hehehe. Best regards. – GTRONICK Jul 27 '16 at 18:47
0

I finally could fix it by the

 sudo update-alternatives --config x-www-browser

mentioned in other threads before.

Only I had to remove Chrome and Firefox before because update-alternative got an error (it said something like "there are no browser installed".. I'm sorry I didn't copy that)

So now I've chosen Firefox again as system-default and until now it does what it's supposed to do.

(anyway it's strange that the Default Settings of the System itself didn't work at all)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.