4

i'm trying to enable remote desktop on my xubuntu machine with xrdp.

I am on a (pretty much) vanilla xubuntu install. I installed xrdp with apt-get.

My xrdp config looks like this:

[xrdp1]
name=sesman-Xvnc
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=-1

netstat -ato shows that something is listening on port 3350 at least:

tcp        0      0 localhost:3350          *:*                     LISTEN      off (0.00/0/0)

I am able to connect over port 3389 to the xrdp screen, where I choose the sesman-Xvnc option, and enter my username and password. The Connection Log window then comes up saying

connecting to sesman ip 127.0.0.1 port 3350

Then it sits there forever. I am able to click the OK button and exit at any time.

Why doesn't it connect?

  • From where are you trying to connect? are you tunnelling port 3350 to port 3350 of your localhost? if so, please edit your question to include details – steeldriver Jul 27 '16 at 12:21
  • @steeldriver edited – Nacht Jul 27 '16 at 12:34
  • Was this resolved? How'd you fix it? – Anonymous Person Jul 28 '17 at 20:02
  • @AnonymousPerson it was never resolved :( i still havent got it to work. – Nacht Jul 29 '17 at 0:34
  • My exact same problem! – Anonymous Person Jul 30 '17 at 5:09
1

These two steps will sort out your issue:

sudo apt-get install tightvncserver
gsettings set org.gnome.Vino require-encryption false
1

Ugh. Somehow, I never realised that localhost wasn't immune to the firewall.

I added an iptables rule for the localhost interface, and now it works.

iptables -A INPUT -p tcp -m multiport --destination-ports 3350 -i lo -j ACCEPT

In the future I'll use this rule to make sure all localhost traffic is allowed:

iptables -A INPUT -p tcp -i lo -j ACCEPT
  • exactly my problem. not sure how iptables is connected but it worked. – Triamus Feb 15 '18 at 14:32

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.