1

Just did clean install of Ubuntu 16.04. Everything was good, but the screen kept flashing after booting to desktop. The default X.org X server was set. I have a Geforce 7025 / nforce 630a video card. So, I set it to NVIDIA legacy binary driver version 304.131, the only option available. Now my Ubuntu splash screen is HUGE. I don't want to Bork my install so, how to bring back the normal size of the splash screen? I've tried these repairs below, but no joy.

Enabling Nvidia driver messes up splash screen How to fix plymouth (splash screen) in all Ubuntu releases!

0

two things

First,

fix grub resolution:

sudo nano /etc/default/grub

Now, locate the line

#GRUB_GFXMODE=640x480 

and change it to this:

GRUB_GFXMODE=1280x800 
GRUB_GFXPAYLOAD_LINUX=keep

Set to your screen default instead of 1280x800 (1360x740 for example).

Next,

add framebuffer:

echo "echo FRAMEBUFFER=y" | sudo tee /etc/initramfs-tools/conf.d/splash

This is not a typo echo is supposed to be written twice just as it says.

finally, update grub and initramfs:

sudo update-initramfs -u
sudo update-grub

reboot for the changes to take effect

| improve this answer | |
  • No Joy. I even changed the resolution to match settings in "sudo hwinfo --framebuffer" no change. Thank you for assisting. – rev dwbsr Jul 28 '16 at 9:03
  • Well I guess no solution. When I use the default X.org driver it flashes like mad and it's very disturbing. When I use the NVIDIA legacy binary driver version 304.131 driver, Ubuntu splash screen is HUGE. So, I guess I'm stuck with the huge splash screen until someone comes up with a solution. Thanks. – rev dwbsr Jul 30 '16 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.