4

Very new ubuntu user here.

I just updated ubuntu (running on virtualbox on windows) from 16.04 to 16.04.1.

When I rebooted my vm - all of the menus, panels, minimise/maximise/close elements were not visible. I have since managed to get the menus to appear as per screenshot below. I am able to right-click and open a terminal session and run programs (as per pgadmin3 running on the right-hand side of the desktop). If I right-click and open an additional terminal session, it is superimposed on the first, and I cannot alt-tab or alt-~ to any other terminal session.

enter image description here

In addition, I am unable to move windows, yet move windows is checked in ccsm.

I have tried the top-rated answers for the following questions without success:

Any help would be really appreciated!

12
  • Is Desktop Wall checked in CCSM ? Jul 27, 2016 at 7:36
  • no - should it be?
    – Sean
    Jul 27, 2016 at 7:37
  • Yes. Check it. See if it allows you move windows Jul 27, 2016 at 7:37
  • checked it, couldn't move windows. rebooted, checked that it was still checked (it was) couldn't move windows :-/
    – Sean
    Jul 27, 2016 at 7:41
  • 1
    See my screenshot. imgur.com/a/Z9ssR Typically issues with moving windows or workspaces come from compiz plugins not being checked. Unity plugin is the most important one - without it there's no decorations or launcher . It doesn't show in the main panel, but if you click on it, the right panel has option for checking it. Jul 27, 2016 at 7:45

4 Answers 4

1

You need to disable the ccsm "window decoration" as it conflicts with the newest unity plugin.

Also, you need to enable the unity plugin in ccsm.

When using unity, all you need to do is click and drag down from the top panel to grab a window to move it.

I have found that alt button1 is a good option for the move plugin that works. Just press alt and hold down left click to move a window.

enter image description here

enter image description here

10
  • 1
    window decoration is (was already) disabled. Unity is currently selected as the profile for ccsm. I'll do some googling now to work out how to find out if it is enabled or not.
    – Sean
    Jul 27, 2016 at 7:36
  • @Sean In 16.04 there is a unity plugin. Enable this plugin.
    – mchid
    Jul 27, 2016 at 7:38
  • sorry for this - but to clarify - if unity is running - does this mean that it is enabled? (please see my screenshot in the question) On a separate note, I can't move the windows at all (either click-hold or using alt...)
    – Sean
    Jul 27, 2016 at 7:39
  • @Sean No, I don't think so. I believe compiz is running and unity is simply a compiz plugin. I have added some photos. Also, disable gnome compatibility if it is enabled.
    – mchid
    Jul 27, 2016 at 7:43
  • 1
    Unity in reality is nothing more but a compiz plugin. Compiz is the actual window manager. If it doesn't have Unity enabled , windows wont have decorations or any shortcuts for moving, alt-tabing, no workspaces either. Time to time compiz crashes ( that just happens for whatever reason ) and i found over and over that you need Unity plugin checked. That's 99% of cases Jul 27, 2016 at 7:49
0

I ran into the same problem yesterday after updating. I haven't been able to fix it, but I figured out a way to avoid it, by using i3 as my GUI instead of the the one that comes standard with Ubuntu. https://i3wm.org/docs/repositories.html

1
  • okay cool. I did install mate (to see if the issue went away) - but it didn't make a difference. I might try i3 and see if that is any different :-)
    – Sean
    Jul 28, 2016 at 8:32
0

Uninformed Ubuntu user. The behaviour of Gnome windows changed after I messed up with the BIOS, setting up for UEFI and back for non-UEFI BIOS.

As a result, all new windows from Gnome opened too towards the left and too towards the top. And I could only move/resize windows with the ALT+move trick (for the first time; after I ALT+moved the window, the behavior was normal). Windows opening in LibreOfficee (for example) behaved correctly.

After messing up for a while trying the recipes from this thread (without success) and others, I found the solution by opening CCSM from terminal -> Window Management -> Place windows -> General (tab) > uncheck "Workarounds" (+ all other suggestions from this thread) Hope this can be helpful

Pablo

0

Enabling Place Windows plugin on CompizConfig Settings Manager did a trick for me.

BTW. I also have enabled Move Window and disabled Workarounds

And thank you for remebering abount Alt + Left Mouse for move the window!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.