0

I have an intel wireless 8260 card in my Dell XPS 13 Developer Edition laptop. The other day I was browsing on chrome when my computer froze. I waited about an hour, and nothing happened, so I help the power button and shut the system down. Ever since then, my wifi doesn't work. The "Enable Wifi" option in the drop down network menu is gone.

I have tried every solution that I can find online, including those pertaining to this exact issue with this exact card. I have done every step in the answers in the following posts with no success whatsoever:

New to linux, need to find and install my wireless driver AC-8260

Intel wireless 8260 - unclaimed network

These steps included reinstalling both the firmware and drivers and attempting some other tweaks. None of this has worked.

Edit: Here is some relevant console output:

~$ lspci -nnk | grep 0280 -A2
3a:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
    Subsystem: Intel Corporation Device [8086:0050]

~$ sudo lshw -C network
  *-network UNCLAIMED     
       description: Network controller
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:3a:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:dc200000-dc201fff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: usb0
       serial: 02:0e:56:3b:0a:03
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.240 link=yes multicast=yes

~$ sudo modprobe iwlwifi
modprobe: ERROR: could not insert 'iwlwifi': Required key not available


~$ iwconfig
usb0      no wireless extensions.

lo        no wireless extensions.


~$ ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:23816 (23.8 KB)  TX bytes:23816 (23.8 KB)

usb0      Link encap:Ethernet  HWaddr 02:0e:56:3b:0a:03  
          inet addr:192.168.42.240  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: 2600:1008:b04e:ba6c:e:56ff:fe3b:a03/64 Scope:Global
          inet6 addr: 2600:1008:b04e:ba6c:405d:920a:be60:9e14/64 Scope:Global
          inet6 addr: fe80::e:56ff:fe3b:a03/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:951 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:690787 (690.7 KB)  TX bytes:221308 (221.3 KB)

~$ dpkg -l | grep -i udev
ii  gir1.2-gudev-1.0                                      1:204-5ubuntu20.19                                  amd64        libgudev-1.0 introspection data
ii  libgudev-1.0-0:amd64                                  1:204-5ubuntu20.19                                  amd64        GObject-based wrapper library for libudev
ii  libudev1:amd64                                        204-5ubuntu20.19                                    amd64        libudev shared library
ii  libudev1:i386                                         204-5ubuntu20.19                                    i386         libudev shared library
ii  system-config-printer-udev                            1.4.3+20140219-0ubuntu2.6                           amd64        Printer auto-configuration facility based on udev
ii  udev                                                  204-5ubuntu20.19                                    amd64        /dev/ and hotplug management daemon

And the following give no output:

~$ dmesg | grep iwl
~$ rfkill list all
~$ lsmod | grep iwl
~$ sudo dpkg --configure -a

Edit 2:

Here is more output requested in comments below:

~$ uname -a; dkms status
Linux xps13 3.19.0-65-generic #73~14.04.1-Ubuntu SMP Wed Jun 29 21:05:22 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
btusb-iwlwifi-intel8260, 1.7, 3.19.0-33-generic, x86_64: installed
btusb-iwlwifi-intel8260, 1.7, 3.19.0-61-generic, x86_64: installed
btusb-iwlwifi-intel8260, 1.7, 3.19.0-64-generic, x86_64: installed
btusb-iwlwifi-intel8260, 1.7, 3.19.0-65-generic, x86_64: installed

I just included what seemed to be relevant

  • Please edit your question and add output of uname -a; dkms status terminal command. – Pilot6 Jul 27 '16 at 6:26
  • See askubuntu.com/questions/802159/… – Pilot6 Jul 27 '16 at 6:28
  • @Pilot6 I've added the output. And I will give that a try, thanks. – user540997 Jul 27 '16 at 6:34
  • Hold on. I am on an answer. – Pilot6 Jul 27 '16 at 6:34
0

You need to remove the custom dkms module and upgrade the kernel.

Now Ubuntu kernels do not load 3rd party modules if Secure Boot is enabled. But the new the 4.4 kernel supports this adapter without any external modules.

Connect to internet by wire and run in terminal

sudo dkms remove btusb-iwlwifi-intel8260/1.7 -all
sudo apt-get install linux-generic-lts-xenial

Reboot.

Now you do not need custom modules. Kernel 4.4 supports this adapter.

An altermnatie way is to disable Secure Boot in BIOS. But keeping a custom moudule is not very good.

  • Hm. My laptop is having a very hard time starting now, it's sitting on a pink screen. I'll update asap – user540997 Jul 27 '16 at 6:52
  • You can always boot from a previous kernel using grub menu. – Pilot6 Jul 27 '16 at 6:53
  • Ok so the 4.4 kernel isn't working for whatever reason. Leads to a pink screen. Booting with 3.9 does work, and now my WiFi is suddenly working. Strange. – user540997 Jul 27 '16 at 7:00
  • Maybe they added support to 3.19 too. Now you can remove kernel image and headers 4.4, if it does not work. – Pilot6 Jul 27 '16 at 7:01
  • But why should it not work? – user540997 Jul 27 '16 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy