1

i have Ubuntu 14.04 and i installed lxc then 1.0.8 was installed. But i needed 2.0.x version hence i upgraded it using following commands.

sudo add-apt-repository ppa:ubuntu-lxc/daily
sudo apt-get update
sudo apt-get install lxc 

After the update when i want to start container there is error as shown below.

lxc-start: lxc_start.c: main: 344 The container failed to start.
lxc-start: lxc_start.c: main: 346 To get more details, run the container in foreground mode.
lxc-start: lxc_start.c: main: 348 Additional information can be obtained by setting the --logfile and --logpriority options.

My OS is up-to-date and upgraded.

1

You should run:

lxc-start -F -l DEBUG -n <container name>

To find out the root cause of the issue.

In my particular case it was:

Permission denied - could not access /var/lib/lxc. Please grant it 'x' access, or add an ACL for the container root.

Which was fixed by chmod +x /var/lib/lxc

  • I followed your suggestion but the following error was displayed. root@avinash-OptiPlex-3020:/home/avinash# lxc-start -F -l DEBUG -n sairam lxc-start: conf.c: instantiate_veth: 2595 failed to attach 'veth11IIJ7' to the bridge 'lxcbr0': Operation not permitted lxc-start: conf.c: lxc_create_network: 2872 failed to create netdev lxc-start: start.c: lxc_spawn: 1080 failed to create the network lxc-start: start.c: __lxc_start: 1353 failed to spawn 'sairam' lxc-start: lxc_start.c: main: 344 The container failed to start. Can you suggest something now – B V Avinash Sep 8 '16 at 5:41
  • It looks like you've hit bug #1406925, there's a fix there that you can try (adding lxc.aa_allow_incomplete = 1). Let me know if that works. – Emil Burzo Sep 8 '16 at 6:04
  • Error remians same but when I debuged it the following error was show lxc-start: lxc_start.c: main: 295 Executing '/sbin/init' with no configuration file may crash the host – B V Avinash Sep 8 '16 at 9:08
  • The initial error seems to be related to lxcbr0, it's either missing or you have something restricting access to it. Can you also check bug #1240757 and bug #1451232 ? If those don't fix it, can you send the output of brctl show ? – Emil Burzo Sep 8 '16 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.