41

I keep getting this error dialog with an Unable to mount error E_FAIL ( 0x80004005 ) when I try to mount Guest Additions:

enter image description here

I tried the Force Unmount, but that just closes the dialog with no action taken. If I then reattempt to mount Guest Additions, I just get this same dialog box again. Any help would be greatly appreciated!

10 Answers 10

37

Finally, I figured it out. Here is how you get arount this. First, load Disk Utility and manually eject the disk in the CDROM, by clicking on the Eject button, after selecting the CDROM device. Then try to remount Guest Additions using the key combination Host + D and voila, Guest Additions should mount successfully.

5
  • 1
    Just a quick note, I tried this today and was unable to eject the media. I had to go down a little further on the page and select "Unmount Volume", and then I was able to Eject. Oct 14, 2013 at 23:37
  • 1
    I believe disk utility is a GUI application, yes? How can I achieve what you accomplished here through the command line?
    – smilebomb
    Dec 17, 2014 at 15:42
  • 1
    Yeah, I'm unable to find "Disk Utility" via the console that you get when you press ALT + F2. Not sure how everyone else managed to find it.
    – Mitch
    May 20, 2015 at 10:57
  • 1
    @Mitch go to the unity launcher (top icon on the left hand column) and type disk utility into the search. it's just called 'disks' in ubuntu 14.04. you should see the CD/DVD drive in there.
    – user137717
    Jul 16, 2015 at 22:25
  • 1
    Point of clarity for anyone it helps: Guest Additions come with virtualbox which runs on your native OS, but can be installed for the guest operating BY the guest operating system. You don't have to install something in the native OS for virtual box itself to use. There are the options listed here to install the Guest Additions from within the guest OS but VB gives the option to 'insert guest additions cd image' from the devices menu which attempts to install automatically, but can fail.
    – user137717
    Jul 16, 2015 at 22:33
28

I came across this today and it seems it could not be fixed via GUI operations. So I did it via command line. It worked like a charm!

  1. Devices -> Install Guest Additions...(it's like insert a cd to cdrom drive)
  2. Open a terminal to login the guest machine
  3. Type below

    sudo mkdir --p /media/cdrom
    sudo mount -t auto /dev/cdrom /media/cdrom/
    cd /media/cdrom/
    sudo sh VBoxLinuxAdditions.run
    
  4. You now can do full screen, shared folder, clipboard sharing, etc

7
  • How did you activate the full-screen etc. After doing that still doesn't show them. Oct 27, 2014 at 12:58
  • By restart the virtualbox one more time, it will work. At least for my case
    – Ace
    Oct 27, 2014 at 17:07
  • Hi, you saved my life dude, good job :)
    – Rubendob
    Aug 27, 2015 at 7:47
  • This worked for me when the others didn't , thanks mang.
    – qbert65536
    Dec 1, 2015 at 21:28
  • You @Ace it buddy. Well done
    – Andy K
    Feb 24, 2016 at 17:15
11

I could not get the autorun to work, installed manually by doing:

cd /media/VBOXADDITIONS_4.2.4_81684/
sudo sh VBoxLinuxAdditions.run
2
  • thanks! this worked nicely and all from cmdline. Only path to additions may vary, for me it was - 'cd /media/kerim/VBOXADDITIONS_4.2.10_84104/'
    – kerim
    Apr 3, 2013 at 10:12
  • I had to perform a mixture of this step and Michael Goldshteyn's steps: 1) sudo palimpsest for complete access to device and eject. 2) remount disk 3) sudo sh /media/VBOXADDITIONS_4.3.6_91406/VBoxLinuxAdditions.run did the trick.
    – Screenack
    Dec 21, 2013 at 14:42
4

Unmounting the volume on devices -> CD -> Remove disk from virutal drive

This will show the "Remove disk from Virtual drive" option as disabled on the same page once you clicked.

Then Press Host (Keyboard:Right Ctrl) + D i.e Host+D

This started working installing automatically on my Ubuntu screen.

2

I had to add one more step.

  1. Unmount Volume
  2. Eject
  3. Rerun Install Guest Additions
1

I ran into this error under this scenario.

  1. Turned on Fedora 18
  2. Opened Terminal, Logged in as root
  3. Attempted to install Guest Additions. It failed with a package missing error
  4. Installed the package and rebooted the system
  5. Logged in as guest user and attempted to run Guest Addition, as I was thinking logging in root is not necessary

No matter how many tries I did, I kept on running into VERR_PEM_MEDIA_LOCKED error.

Trying to install by logging into root made this error go away.

So, it seems the OS somehow remembers the user you tried to run the Guest Additions first time, and in successive runs, if you are not logged as that user, it complains.

1

For linux host it can be done as follows. Open the os in virtualbox whose resolution you want to change and follow the following steps.

  1. sudo gedit /etc/fstab
  2. enter root password
  3. Change this line

    /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0

                                  **to**
    

    /dev/sr0 /media/cdrom0 udf,iso9660 user,exec 0 0

    save it and close it.

  4. Press ctrl+D
  5. Guest additions will install now.
  6. Reboot . press ctrl+f.

precaution

In step 1 , you can use any text editor instead of gedit , which may be present in your distro.

Source/Credit

https://forums.virtualbox.org/viewtopic.php?f=3&t=58799

0

Here is what I followed and it worked. Nothing else. Mine is Ubuntu 14.04 Trusty...

1) Once in Ubuntu, Go to the files folder.

2) On the left side, you will see some options among which there will be "My Computer" and above it "The virtual drive (Named as your ISO file)"

3) Right click on it and select eject.

4) Go back to the "VIRTUALBOX" and go to devices option and select Install Guest Addition CD Image.

5) Hopefully, you wont get the same error.

6) Follow on accordingly. Select "Run". Verify your Password.

7) Let the terminal run and once asked, press enter.

8) Reboot your Virtualbox and this time you will notice the full resolution version.

0

The above solution only partly worked for me. The .iso doesn't show as mounted unless the disk is removed using the Virtualbox Manager (Machine > Settings > Storage). Once properly mounted (Devices > Insert Guest Additions CD Image...), I needed to copy the autorun utility:

cp /media/cdrom/VBoxLinuxAdditions.run ~/Desktop

Then make it executable:

chmod +x ~/Desktop/VBoxLinuxAdditions.run

And finally:

sh ~/Desktop/VBoxLinuxAdditions.run

Not sure exactly why other methods didn't work for me, but this is how I was able to install it successfully.

0

I got this dialog when tried to "insert" already mounted guest additions disk, that' s why (but effectively it was already 'inserted' so it was possible to follow the installation instruction despite of error message)

1
  • this answers my situation googling which I find this closest question Jun 17, 2018 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.