6

I want to be able to select certain text with mouse to copy and paste it to the commandline. The "select" and "paste from clipboard/primary selection" part works, but I am unable to copy the selection to the clipboard (verified with xsel).

So far I have tried:

  • selection (I think it had been working some time ago),
  • Ctrl+Shift+C
  • RMB/Copy
  • Edit/Copy

I use Ubuntu server 14.04.4 and xfce4-terminal 0.6.3

MMB, Shift-Insert and Ctrl+Shift+V works when I populate the clipboard from elsewhere.

The answers to the 4 years old question Why can't I copy text from the Ubuntu Terminal? were not helpful.

5

You can use clipman to sync selections and paste it anywhere using the middle click of your mouse. Just, select some text, open the terminal, and press the middle click. You can play with the options to adjust it to your preferences. To install clipman, use:

sudo apt-get install xfce4-clipman

Or, if you prefer, install the complete set of utilities for XFCE, using:

sudo apt-get install xfce4-goodies
  • 1
    I would never think about installing an external program when I have explicit "copy" option in the menu. I am glad we have a community which helps us with issues like that. – abukaj Jul 27 '16 at 6:40
  • This worked great for me on Debian stretch, too, copying both from and to an emulated terminal. – hBy2Py Jun 25 '18 at 2:10
0

I suggest to use Clipit. It is a very simple yet effective program, it is under the terms of the GNU General Public License, so it is completely free, you can get it from:

https://sourceforge.net/projects/gtkclipit/

Cheers

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.