This question already has an answer here:

After the recent update I wasn't able to start my system (black screen). So I powered off the PC and turned it on again.

Saw the following grub menu:

Advanced options for Ubuntu
System setup

I selected "Advanced options for Ubuntu" and saw:

Ubuntu, with Linux 4.2.0-42-generic
Ubuntu, with Linux 4.2.0-42 ... (recovery mode) ...
Ubuntu, with Linux 4.2.0-41-generic
Ubuntu, with Linux 4.2.0-41 ... (recovery mode) ...

I selected Ubuntu, with Linux 4.2.0-41-generic and the system started (previously with Ubuntu, with Linux 4.2.0-42-generic selected it didn't)

As I didn't always want to select it manually I tried to set it as the default kernel in grub: So I opened '/etc/default/grub' and changed:


Then executed $sudo update-grub and restarted the system. But it still wanted to load the latest kernel.

I also tried it with GRUB_DEFAULT=3 but the result was the same.

My grub is:

#grub-install --version
grub-install (GRUB) 2.02~beta2-9ubuntu1.11

I also got some errors while installing grub customizer:

dpkg: dependency problems prevent configuration of linux-signed-generic-lts-wily:
 linux-signed-generic-lts-wily depends on linux-signed-image-generic-lts-wily (=; however:
  Package linux-signed-image-generic-lts-wily is not configured yet.

dpkg: error processing package linux-signed-generic-lts-wily (--configure):
 dependency problems - leaving unconfigured
Setting up grub-customizer (5.0.6-0ubuntu1~ppa1t) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I'm not sure whether I should reboot or uninstall it...

marked as duplicate by Fabby, pomsky, Zanna, Eric Carvalho, waltinator Mar 18 '18 at 15:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Ok, I installed the grub customizer and set:

default entry
   predefined [Advanced options for Ubuntu>Ubuntu, with Linux 4.2.0-41-generic]

After this I noticed that the following entry appeared in /etc/default/grub:

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 4.2.0-41-generic"

Then I uninstalled the grub customizer made sure the entry was still there ran sudo update-grub and rebooted. Now the right kernel is used.

It looks like there is a specific syntax GRUB_DEFAULT="submenu>menu". Didn't know about that...

Not the answer you're looking for? Browse other questions tagged or ask your own question.