2

I am dual booting ubuntu and windows 10 on my laptop. I recently installed the plex server and followed the instructions on this link to fix a permissions issues I was having. Now however, ubuntu will not boot unless the hard drive is plugged in. When it is not plugged in, the purple ubuntu screen comes up and then goes to a black screen that says "welcome to emergency mode". I try pressing ctrl-D to continue but it just goes back to the emergency mode screen.

Thanks in advance!

  • What is on that external hard drive? Ubuntu seems to think it needs something from it. Is it automounting it? – tlhIngan Jul 25 '16 at 22:00
  • 2
    Did you put the external hard drive in /etc/fstab? – Nobody Jul 25 '16 at 22:41
0

Funny you ask, because I saw that today in our lab just today.

Drives are lettered in the order they are found, sda, sdb, and so forth. Those letterings can be shifted when new devices are inserted. If the old config is looking for a partition in a place, but it finds MS Windows instead, for example, then blam!

If you put settings in /etc/fstab using drive letters, then the setup is fragile because the letters change when something is unplugged. I saw exactly the error you describe.

If your /etc/fstab file uses UUID names for devices, this won't happen. Know what I mean? Use this sort of entry, rather than one that begins /dev/sdXX:

UUID=bc9f628b-8ad3-4cff-910b-d1ee751c4790 /boot           ext2    defaults        0       2

If you start the working system, then run

$ /sbin/fdisk -l

to list the drives. I'm assuming you have old style partitions. If you have GPT, problem is likely same, but details differ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.