6

I've recently installed Ubuntu 16.04 and I'm having the following problem:

Whenever I open a file with VLC, I cannot hear anything and an error message popups with the following:

Audio output failed:
The audio device "default" could not be used:
Connection refused.

Other media players work fine (SMPlayer for example). Any suggestions?

4

Certainly if there is sound working in other media players there is obviously a local problem with sound in vlc. Two suggestions that should fix the problem to try in order:

  1. Reset the vlc config to defaults by running the following command:

    vlc --reset-config --reset-plugins-cache
    

    This may be enough to rectify the issue but if not try the following:

  2. Follow this path in vlc:

    Tools >> Preferences >> Audio >> Output >> Output Module
    

    And select a different 'Output Module' from the drop down box. This screenshot illustrates the choices under a default vlc installation on Xenial Xerus:

enter image description here

Some experimentation may be required with these options until you find a happy option that produces sound...

| improve this answer | |
  • Hello, thanks for answering. I found the problem to be firejail. Namely, this issue: github.com/netblue30/firejail/issues/69 – iamatrain Jul 26 '16 at 11:31
  • @iamatrain Good to hear that you have resolved the issue. Mind you this probably means that altering the Output Module to 'ALSA audio output' would have have also worked if not actually got to the bottom of the issue... – andrew.46 Jul 26 '16 at 11:34
  • It works!, my vlc was constantly crashing, I have manjaro, and the error was: too low audio sample frequency (0) when I run it from console. After doing vlc --reset-config --reset-plugins-cache everything looks ok again. Thanks! – Rodrigo Apr 7 '18 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.