0

nouveau issues. Can I install graphic drivers when its loaded like "quiet splash nomodeset"?

I tried stopping lightdm, blacklisting modules and updating initrams but can't install NVidia, it says nouveau is still being use the kernel. If blacklist them and reboot then both my monitors will show blank screen and I have to ctrl alt del reboot.

Will it work fine if installed and rebooted to without nomodeset?

If I can install in nomodeset, then I can boot again and run nvidia-xconfig and hope it works fine?

4
  • It is a VERY bad way of installing Nvidia drivers. Do not blacklist anything and do not install from a .run file. You can easily find how to install drivers properly. – Pilot6 Jul 25 '16 at 16:20
  • Why is it bad? Does the graphic stuff have to work while we install? I was only black listing nouveau modules so it the manual install would work. I guess I'll try apt-get install NVidia-### whatever version is available then.... I wanted to try a specific version from the website and if it fails then run ./nividia.##.run --uninstall and then install whatever is available in apt-get. – John Doe Jul 25 '16 at 16:30
  • It is bad because it is not an Ubuntu way. After a first kernel upgrade the system will not boot, especially if you blacklist nouveau. You can install drivers from Ubuntu repos or a PPA. You can install any version you need from PPA. – Pilot6 Jul 25 '16 at 16:36
  • Cool. Don't know anything about ppa. Will check that and install it. Thanks – John Doe Jul 25 '16 at 17:01
1

To future Googlers:

Install Nvidia drivers first, and then blacklist nouveau. Reboot the machine.

Your first goal is to make sure that at lease one monitor is working fine with Nvidia driver. In case if you get into graphic issue, press Ctrl+Alt+F1 for terminal access and you can remove/purge the driver OR install a different version of Nvidia driver.

That will ensure both your graphic cards are using Nvidia drivers. If you don't blacklist Nouveau then one graphic card will be using Nvidia and other will be using Nouveau that means you can never get your second monitor working unless both graphic cards use same driver in this case.

Run lspci -vnn | grep -i VGA -A12 to verify which driver vendor is in use. Check the line "Kernel Driver in Use". If you don't see that line, increase -A12 to -A20 (After the match, number of lines).

Now that you use Nvidia, you can move ~/.config/monitors.xml to ~/.config/monitors.xml.old. Having this might sometime conflict with xorgs. So better move the file and then start editing xorgs.

Run nvidia-settings command and make resolution auto and enable Xinerama. Save the config to /etc/X11/xorg.conf

Restart lightdm and see if works.

If not, edit xorgs.conf, tweak everything related to screen 1 and device 1 configuration parameters. Compare it with Device 0/Screen 0 settings and make changes accordingly. Just make sure PCI/BUS ID is unique and correct one. After proper changes, restart server lightdm to see if it works. Most of the time the main reason for secondary monitor not working as expected it resolution issue, feel free to test by lowering resolution for screen 1 (secondary monitor) in the config. Either way try and make it similar to working screen in xorgs.conf.

There are other posts related to this that should help you get it fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.