1

Ok so to start with I have an Alienware X51 R3 desktop computer. Yesterday I decided that I wanted to be able to dual-boot Windows 10 (the default OS) and Ubuntu 16.04. So to do this I freed up 40g of space on my C: partition and installed Ubuntu from a bootable flash drive. The installation went well, but I had issues getting GRUB to appear, my computer went straight to Windows 10. I found out that I had to turn the fast startup off, and since my computer's BIOS is UEFI, I had to turn safe boot off. So nice, now everything works great, but the GRUB boot menu looks pretty dull. So I looked up a tutorial to get BURG and entered in the following commands into the terminal:

sudo add-apt-repository ppa:n-muench/burg
sudo apt-get update
sudo apt-get install burg burg-themes

The next command is where I encounterd and issue and it was:

sudo burg-install "(hd0)"

I encountered and error that said, " /usr/sbin/burg-setup warn: this GPT partition label has no BIOS Boot Partition; embedding won't be possible!" To fix this I found a guide and entered the following commands into the terminal:

sudo parted /dev/sdb set 1 bios_grub on  

After this I retried

sudo burg-install "(hd0)"

, and it worked.After this I used the command:

sudo update-burg  

Then I toyed around with the themes in the BURG emulator and chose one I liked. Now I was satisfied so I went to reboot my computer, but instead of the GRUB, BURG, or even Windows OS booting, I got and error message saying, "Internal Hard Disk Not Found, no bootable devices." ...When this happens I cant do anything but run diagnostics or edit my BIOS settings. I ran diagnostics and there are no errors to be found. I went to the BIOS settings and they were fine, the boot order was as always. One thing I figured out was that when I turn safe boot for UEFI off, it also turns on Legacy Rom boot mode that has a safe boot, (this was originally fine with GRUB before I installed BURG). So I tried turning the Legacy safe boot off too, and brings the GRUB menu back when I reboot, but there is no longer an option for Windows 10.. I've tried Ubuntu's boot repair and this doesn't help either. I'm so confused as what to do, and spent so much time searching and found no answers. If someone could help you would be a life saver, I have too much data to loose on my Windows filesystem.

  • 1
    I'm almost certain that BURG doesn't support EFI, which would explain what happened. You can try downloading boot-repair and booting into that to get GRUB back. Make sure you're in EFI mode when you do this. – TheWanderer Jul 25 '16 at 15:51
1

First get your Ubuntu installation disk and boot in live mode. Open a terminal and run:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt update
sudo apt install boot-repair

then run:

sudo boot-repair

Chose recommended options. After a bit it will ask you to paste text in terminal. Select all and paste in new terminal window. It will do this twice.

If this is fruitless you can try accessing Windows data from your live disk and backing it up.

Hope this is helpful!

|improve this answer|||||
1

AFAIK, BURG is a BIOS-only boot loader; it will not work in a dual-boot configuration alongside Windows installed in EFI mode (as is the case for the vast majority of computers that ship with Windows 8 and later). To recover, you must re-install, or at least re-enable, an EFI-mode boot loader. There are at least three ways you can do this:

  • Go into your firmware setup utility and disable the Compatibility Support Module (CSM; aka "legacy support"), as described on this page of mine. With this done, with any luck the computer should begin booting to GRUB again, or perhaps to Windows. If not, you might need to fiddle with the boot order or follow one of the next two suggestions. If it does work, this approach is the least intrusive and the least likely to present follow-on problems.
  • You can use the Boot Repair tool to re-install GRUB. You'll need to run it from an emergency disk (the Ubuntu installation medium should do). In theory, this will get you back to more-or-less where you were before you tried to install BURG.
  • You can use my rEFInd boot manager on a USB flash drive or CD-R to boot into Ubuntu, then install rEFInd from its Debian package or PPA (or re-install or recover GRUB). Since it sounds like you dislike GRUB because of its plain text-mode display, you may find rEFInd interesting, since it features a graphical and theme-able interface.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.