1

I'm using a BIOS raid1 with Marvell chipset which works really well with dmraid in Ubuntu 14.04.

The disk is shown as the following name with command fdisk:

Disk /dev/mapper/ddf1_00000000000000004b1b92914b1b92914b0400004b040001: 2000.3 GB, 2000315047936 bytes
255 heads, 63 sectors/track, 243191 cylinders, total 3906865328 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x3b9fee89

                                                         Device Boot      Start         End      Blocks   Id  System
/dev/mapper/ddf1_00000000000000004b1b92914b1b92914b0400004b040001p1            2048  3906865151  1953431552   83  Linux

Disk /dev/mapper/ddf1_00000000000000004b1b92914b1b92914b0400004b040001p1: 2000.3 GB, 2000313909248 bytes
255 heads, 63 sectors/track, 243190 cylinders, total 3906863104 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/ddf1_00000000000000004b1b92914b1b92914b0400004b040001p1 doesn't contain a valid partition table

However, after I do a fresh install to Ubuntu 16.04 the disk is detected as /dev/sdb and /dev/sdc. Mounting these hard drives only get error with unknown type ddf_raid_member. Installing dmraid doesn't help either. Using command sudo dmraid -ay only returns no raid disk.

But luckily, I'm still able to access the raid device with Ubuntu 14.04 Live CD. How can I make the raid device work again in 16.04? Thanks!

Update 2016/07/26

I've rolled back to Ubuntu 14.04. The fakeRaid device is still able to work normally. Does this means that Ubuntu 16.04 doesn't support dmraid correctly?

Update 2016/08/06

I've tried to install mdadm in Ubuntu 16.04.1, but mdadm only tells me that the hard drives does not have superblocks and cannot be reconstructed.

1

I'll try to get a better answer. For now, you have to run

sudo dmraid -ay

from the BusyBox prompt or go live with the disc, run it terminal, then install to the array.

To get it into the boot sequence make a text file in

/etc/initramfs-tools/scripts/init-premount

with the code

exec dmraid -ay
exec sleep 1

Ensure that you make the file executable then run

sudo update initramfs -k all -uv    

Enjoy!

1
  • Thanks but I've tried this before. Doesn't work. – KKyang Oct 3 '16 at 13:34
0

I had same problem and solved by installing raid support. Try this:

sudo apt-get install mdadm
1
  • 1
    Thanks. But I've tried before, mdadm said my fakeRaid does not have superblocks and cannot reconstruct the hard drives. – KKyang Aug 6 '16 at 11:25
0

I've reported to the launchpad and got fix by the developer. The bug seems to be related the new feature of the 4.4 kernel.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1611277

But the new version of dmraid is not guaranteed on every devices. At least it works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.