11

VirtualBox Installation gives message

sudo modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found.

I have updated system with

sudo apt-get update

followed with

reboot

Ubuntu version: 14.04 LTS

I tried installing with GDebi Package Installer, the message is-

Selecting previously unselected package virtualbox-5.1.
(Reading database ... 800789 files and directories currently installed.)
Preparing to unpack .../virtualbox-5.1_5.1.0-108711~Ubuntu~trusty_amd64.deb ...
Unpacking virtualbox-5.1 (5.1.0-108711~Ubuntu~trusty) ...
Setting up virtualbox-5.1 (5.1.0-108711~Ubuntu~trusty) ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...

Another Try: I disabled secure boot from BIOS and followed

apt-get update
apt-get install linux-headers-$(uname -r)
dpkg-reconfigure virtualbox-dkms
modprobe vboxdrv 

Now modprobe vboxdrv working fine. So I installed VirtualBox with file- virtualbox-5.1_5.1.0-108711~Ubuntu~trusty_amd64.deb with GDebi Package Installer. Now when I start the VirtualBox and start a machine it shows following error-

**RTR3InitEx failed with rc=-1912 (rc=-1912)**

 The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/sbin/vboxconfig'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user. 
17

This helped me:

apt-get update
apt-get install linux-headers-$(uname -r)
dpkg-reconfigure virtualbox-dkms
modprobe vboxdrv 
  • should I reboot anywhere? – Kapil Jul 25 '16 at 14:15
  • 2
    Sorry it didnt work – Kapil Jul 25 '16 at 14:27
  • 1
    I actually did both 1. disabling secure boot and 2. reply of @mwatzer problem of 'modprobe vboxdrv' solved, but still my virtualbox is not working :( – Kapil Jul 25 '16 at 14:50
  • Ok at least one problem is solved .. can you give me a snippet of the current error-message? – mwatzer Jul 25 '16 at 16:28
  • Yes it is solved by removing the virtualbox installed through the file "virtualbox-5.1_5.1.0-108711~Ubuntu~trusty_amd64.deb" and installing by sudo apt-get install virtualbox – Kapil Jul 25 '16 at 16:52
1

This is kind of old, but I finally solved this exact problem on rhel7 (I assume this would solve it for ubuntu too). I was able to solve it by:

booting into the BIOS and going > advanced (f7) > boot > scroll down to "secure boot" > change "Windows EUFI mode" to "other OS"

My virtualbox works perfectly now.

1

Just remove Secure Boot from BIOS and then

sudo apt update 
sudo apt install --reinstall linux-headers-$(uname -r) virtualbox-dkms dkms
0

Just type two commands and everything will work fine......

sudo apt-get update

sudo apt-get install virtualbox-dkms
0

This happened to my VirtualBox after a Windows update. I have a dual boot machine, and only use Windows for certain games. When Windows updated recently, apparently it reset the boot settings to re-enable 'secure' boot. So after I changed the boot settings back to un-enable secure mode, VB worked fine again. The file the VB message said I was missing was there all along, but the secure boot settings apparently kept that file from being able to load.

0

I know im late to the party but non of the answers worked for me. What you have to do is go on the bios settings or the grub (dual boot manager) system configuration and disable secure boot. It will ask you to confirm and once you go to your system the vm will work. Hope it works for anyone with this problem who cant even use modprobe vboxdrv commands like me.

-1

If you recently installed a new kernel version, try the earlier one. Kernel vmlinuz-4.2.0-42-generic doesnt work for me, but vmlinuz-4.2.0-41-generic works. Apparently, there is no vboxdrv version for vmlinuz-4.2.0-42-generic . I'm using VirtualBox 5.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.