3

I am experiencing a weird issue with bumblebee. I have installed bumblebee-nvidia with nvidia-364. Bumblebeed starts, but when I try to connect with optirun, optirun reports:

[ 1225.971452] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) 

[ 1225.971523] [ERROR]Aborting because fallback start is disabled.

The output of bumblebeed reports:

[ 1225.971295] [ERROR][XORG] (EE) 
[ 1225.971305] [DEBUG][XORG] Fatal server error:
[ 1225.971313] [ERROR][XORG] (EE) 
[ 1225.971320] [DEBUG][XORG] Invalid argument for -config
[ 1225.971327] [DEBUG][XORG]    With elevated privileges, the file specified with -config must be
[ 1225.971335] [DEBUG][XORG]    a relative path and must not contain any ".." elements.
[ 1225.971342] [DEBUG][XORG]    Using default xorg.conf search path.
[ 1225.971350] [ERROR][XORG] (EE) 
[ 1225.971357] [ERROR][XORG] (EE) 
[ 1225.971363] [DEBUG][XORG] Please consult the The X.Org Foundation support 
[ 1225.971369] [DEBUG][XORG]     at http://wiki.x.org
[ 1225.971376] [DEBUG][XORG]  for help. 
[ 1225.971382] [ERROR][XORG] (EE) 
[ 1225.971388] [ERROR]X did not start properly

It appears to be correctly connected to the kernel module and have access to correct folders, primus is found, but the problem appears to be related to a bad path in arguments to start xorg. I can't check the path bumblebeed is trying to feed to xorg.

Anybody has some experience with this?

More info: I am aware that it's possible to use nvidia-prime to get switchable graphics and I can get it to work. That however means that I have to restart all programs to get to nvidia, which is impractical. It's much more practical to be able to use intel most of the time and use nvidia only for specific programs.

I am also aware that bumblebee is a bit outdated, but it can be operated even on Ubuntu 16.04 if set up properly (I had it working, but later I broke something unrelated in my system and had to reinstall it).

3

I have found a nice workaround. It was ridiculous. The package primus comes with the primusrun command that does the same as optirun, just better and does not cause that error to appear.

  • For me, it works to do primusrun ls or primusrun xeyes whereas optirun with the same programs give the error above. However, if I try to primusrun a program that actually requires 3D acceleration, I still get the same messages in syslog, and the printout primus: fatal: Bumblebee daemon reported: error: [XORG] (EE). – Supernormal Feb 20 '17 at 7:23
  • Strange. I was capable of running even OpenCL programs and Wine games on the discrete video card via primusrun. What I sometimes needed with OpenCL was to enable the kernel module with sudo modprobe nvidia_364_uvm (if your driver version is 364). – Dugi Feb 20 '17 at 11:03
0
+50

I had errors like this, until I found bumblebee is not supported now. Instead, try using prime:

sudo apt-get install nvidia-prime prime-indicator

Also, check this link for more information.

EDIT: prime-indicator installation here

  • I am aware of that possibility, but that causes the video card to render both the screen and the program that needs the discrete graphic card. Furthermore, I would have to close all graphical programs to switch it. Unsupported bumblebee is not really the problem, because I somehow got it working before. Now when I tried to replicate it, it throws this weird Xorg issue (as if it had trouble to set up the X-server for the secondary screen). – Dugi Aug 5 '16 at 13:45
  • Although your reply didn't answer my question and didn't tell me anything I didn't know before, it has started a chain of events that ended up by me stumbling upon the word primusrun that was the ultimate clue. I am giving you the bounty because why should I don't want the reputation to vanish. – Dugi Aug 7 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.