13

I have a room with pretty weak WiFi signal and my access point has a hidden name, but is correctly configured and saved in network manager.

Sometimes when I lose connection, the AP still appears in the network manager indicator's drop-down menu. Usually this means it is in range again and I can reconnect by clicking, but sometimes trying this pops up a window with this error message:

Connection failure

Failed to add/activate connection

(7) The access point /org/freedesktop/NetworkManager/AccessPoint/24 was not in the scan list.

Checking sudo iwlist wlp3s0 scan confirms that the AP is not in range then, but it refuses to disappear from the indicator menu. Sometimes the entry even survives disabling and re-enabling WiFi and/or networking and even a suspend.

Is this an annoying bug or how can I force network manager to update its scan list properly?


System info:

Ubuntu 16.04, 64 bit, Unity desktop

Version of package network-manager: 1.2.0-0ubuntu0.16.04.3

From lshw:

  *-network
           description: Wireless interface
           product: Wireless 3165
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: wlp3s0
           version: 81
           serial: 08:d4:0c:b3:0b:19
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-31-generic firmware=16.242414.0 ip=192.168.178.27 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
           resources: irq:126 memory:a4000000-a4001fff

closed as off-topic by user117103, waltinator, Eric Carvalho, ravery, George Udosen Nov 30 '17 at 10:49

  • This question does not appear to be about Ubuntu within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 9
    I'm sure you've tried sudo service network-manager restart, right? – Android Dev Jul 24 '16 at 22:51
  • @AndroidDev Not yet, no. Will do that when it happens the next time though, it should not take too long... :-/ – Byte Commander Jul 24 '16 at 23:02
  • Sometimes my computer just outright refuses to connect my wireless AP. However, running the previously mentioned command fixes that for me. – Android Dev Jul 24 '16 at 23:04
  • Have you solved this problem? If yes, you might want to write an answer – Anwar Dec 19 '16 at 15:27
  • 4
    It looks like you were the only one with this kind of problem - so I am voting to close this question as a not reproducible problem – guntbert Nov 29 '17 at 11:01