0

I have Ubuntu running in a VirtualBox VM on both a Windows 7 host and also a Macbook Pro.

Four times now (on two different hosts) after having successfully installed (auto-)updates, and restarted the machine, I get my normal desktop background, but no launcher. I can right-click on the desktop and open up a terminal The terminal window is fixed to to the top left of the desktop, and has no menubar - despite the context menu (right-click) showing the menubar as being enabled.

Alas, almost everything I have tried to do from within the terminal has had precisely no effect. I have tried each and every suggestion I could find from answers to similar issues - eg.:

The only thing that works thus far is running "unity --debug".

Any and all suggestions would be most welcome.

many tias, gary

2

I found the same thing from updating today. Finally found that in ~/.profile there was a line:

export UNITY_LOW_GFX_MODE="1"

If you press ctrl+n on the desktop it'll show your home folder, then ctrl+h will show hidden files.

Open ~/.profile then remove or comment out export UNITY_LOW_GFX_MODE="1".

I also removed my Unity config (I renamed /home/huw/.config/compiz-1 to /home/huw/.config/compiz-1-old)

Then restarted and it was all working. Hope that helps!

1

I'm running Ubuntu under VirtualBox V5.0.24 on macOS 10.11.6 My ~/.profile did not have the export line. However, the rename of ~/.config/compiz-1 worked for me as well.
I did some experiments and found that just trashing ~/.config/compiz-1/compizconfig/config resolved the problems on my setup. Shortly after trashing that file the menu bar and launcher appeared and a new empty config file was created. I suspect an empty config file results in the same effect as the config created after renaming compiz-1 which created a new config (works) containing only the following two lines.

[general_ubuntu-lowgfx]
profile = unity-lowgfx

The old ~/.config/compiz-1/compizconfig/config (that didn't work) had the following lines

[general_ubuntu-lowgfx]
backend = ini
profile = 
integration = true
plugin_list_autosort = true
0

As solution 0 stated, I did not have that export line in ~/.profile. Further, .config/compiz-1 was an empty subdir. Renaming, or deleting that subdirectory creates a new one. However, selecting autohide to yes, breaks the system....this solution above is a recovery of the launcher, not a fix for autohide.

0

Renaming or removing ~/.config/compiz-1 worked for me. Here is what I've done.

  • left-click on the desktop's background and choose "Open Terminal"
  • At the prompt, type

    mv .config/compiz-1 .config/compiz-1-old
    
    sudo reboot
    

After the reboot everything worked fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.