0

Ubuntu 16.04.1 LTS 32bit Server Edition

Computer: Intel Pentium 4 /2.4Ghz 32bit

WirelessNetwork Card: Realtek Chipset/ TPLINK wireless N PCI adapter

I'm new to Linux and Ubuntu. I have been fighting with my computer for months now and I can't seem to ping any outside internet source like google.com; I can ping router and computers on LAN. It worked to connect to the internet during installation to download LAMP stack, but now no sudo apt-get works.

After lots of trouble shooting I know what's not the issues:

  • DNS resolution error: I can resolve google.com to an ip, but I can't ping it or it's IP. resolv.conf is set up correctly.
  • Interface configuration: I have my computer setup to receive configuration from DHCP router. It finds the proper hardware address for my interface and I notice in my IP tables on the router it lists the computer by host name and hardware MAC address properly. I originally had an IP assigned to it outside of the normal IP rage, but for the sake of troubleshooting it is now auto assigned.
  • Firewall Setup: No firewall configurations have been set so I know it's not a faulty firewall configurations dropping incoming packets.
  • Ip Tables: From my understanding these are also correct.
  • TCP Dump: I have run a tcpdump, while pinging google.com and it doesn't receive any packets back, and the tcpdump states that packets are captured and received by filter and kernel doesn't drop any.
  • RF KILL: It can't be that as I can talk to the router and LAN devices.

I started to thing that it was a Gateway issue, but I'm not sure. Here is what I have checked:

  • Faulty Mac Address ip config: I have checked my routers logs and it's assigning the proper IP to the wireless card MAC address on my computer
  • Ping: I can ping google.com from my router and I can ping google.com from my windows7 machine on the same network.
  • Settings: NAT is on; SPI firewall is on; Filter Anonymous Internet Requests is checked; Filter IDENT (Port 113) is checked; SIP ALG is disabled.

OTHER NOTES:

  • I noticed I don't have network manager installed; though I think I have the binary files for it. I think that is just for the GUI app which, since this is a server edition, it doesn't have a GUI.

  • I don't have traceroute installed, I only have traceroute6. It won't let me install traceroute.

  • When I tried Tcpdump with certain parameters it would say: "You don't have permission to capture on this device. (socket: Operation not permitted)."

I can't copy and paste text from my server console so here are pictures of the printout's for:

  1. netstat -nt
  2. route -n
  3. nslookup google.com
  4. interfaces.d
  5. resolv.conf
  6. Ifconfig -a

Print out picture

Any advice would be greatly appreciated. I need to get my server going for projects.

Part 2

I'm convinced this computer is evil and sentient at this point. My brother has recently left and He has an Ethernet port in his room, so following Kamil Kurzynowski advice I was going to setup a wired connection. However, before I took that advice I reinstalled the computer: then things happened. Now it doesn't want to load the kernel module for the ehternet port drivers, so no wired connection is possible; though it works during wired installation of the system. There is apparently no folder in /lib/ called 4.4.0-21-generic. I have tried reinstalling it a few times, once with the wireless card out, and once with no internet connection and just installing basic system utilities, and still it won't load the ethernet drivers.

I also noticed something weird after I installed it a few times. When I was logged in and hit the up arrow it showed commands from way back when I was trying to get it to work with the wireless card. Mind you this is after I tried to reinstall it a few times. I flushed the ram and deleted bash history and reinstalled. When ever I reinstall I just reuse the partition from before; it says that it re-formats it and erases data.

My questions is this:

  • Is there a way to download this kernel modal and install it so I can get it to talk to the drive.
  • Should I blank the hard-drive and reinstall; in case it's not reusing the partition correctly

Picture of readouts

P.S. The live USB I am using is the same one I used to install Ubuntu 16 before this issue occurred. I have also done RAM tests and it says it's fine.

7
  • Have you tried disabling ipv6?
    – pnd001
    Jul 24 '16 at 20:24
  • Can you pls, give me your iptables -L? Can you ping loopback? Do you have any sticy configuration on your router? Do you have any network device beetwen your router and your server? Can you ping your server from outside?
    – nethero
    Jul 24 '16 at 20:29
  • Re traceroute, you should have tracepath installed by default instead, I think Jul 24 '16 at 20:33
  • If traffic is routed successfully within the LAN, it really does point at a gateway issue, no? I wonder if MTU size / fragmentation might be an issue - you could try performing the ping test with different packet sizes as described here Change the size of a ping Jul 24 '16 at 20:39
  • Daniel have Disabled ipv6, but that didn't help. @KamilKurzynowski I have done all the things you listed. The picture below has the readouts for them. Also I can not ping my server outside of network; though I think cause it's not forwarding a port. steeldriver I have run the Ping with paraamters. It says error occurs around 1500; thought it goes to around 1450. The print out is in the picture below. readout picture
    – K.B.G
    Jul 25 '16 at 18:32
0

I would check ip tables of router, server and any device inbetween. Icmp echo may be blocked from outside. I don't know complete network topology so i would not point my finger at gateway so fast. But it is good point, I forgot there is no connection except for address resolution. At this point we need to wait for answer from author.

8
  • I can ping loop back, I don't have sticky configuration, and there are no devices between the computer and router.
    – K.B.G
    Jul 25 '16 at 18:47
  • @steeldriver I tried running the code in your example, but it didn't work; I'm new so I don't know the proper way to run multiple lined code in terminal. However I received an error when I ran this line ping -c1 -s1473 -M do google.com. Ping says it is a local error: Message too long, mtu=1500. 1473 was the highest number that stated to send back an error.
    – K.B.G
    Jul 25 '16 at 20:19
  • It should be 1500 by default for Ethernet and 1492 for IEEE 802.3. You can change your MTU size from command line and then give it a shot. sudo ifconfig eth0 (in my case) mtu 1492. It should be 1492 default for wireless.
    – nethero
    Jul 26 '16 at 8:13
  • I'm running on a wireless card capable of N,B,G IEEE802.11. I changed the MTU to 1492, but didn't work. I also changed it to 1472, since that was the highest number it went to before I got back a ping error. However, I'm still not able to ping google.com.
    – K.B.G
    Jul 26 '16 at 16:10
  • And u sure it has nothing to do with ACLS or IPTABLES? U can resolve address via remote DNS so it feels like only certain packets are dropped. Do you have LAN card on your server? (If yes, then disable it.)
    – nethero
    Jul 26 '16 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.