0

I have a Dell Inspiron 7537 with a Core i7 processor.

I used to dual boot Windows and Linux, which was fine. However later, I ended up booting from Ubuntu 16.04, and making that the only OS installed on my drive. For some reason, I have grub installed.

I don't know if I told it to or what, however I'm thinking it's causing an issue with me being unable to enter my BIOS. If Ubuntu MATE is the only OS on the drive, I wouldn't need grub at all, correct?

  • You should be able to do a cold boot, not warm reboot and press f2 or f12 for UEFI or boot entries. Grub menu also has fwsetup to go into UEFI. askubuntu.com/questions/652966/… – oldfred Jul 24 '16 at 3:32
1

No, grub is needed even if your only OS is Linux. Besides selecting the OS to boot, it also gives you the options to boot to Recovery Mode for example, or select any kernel you want in case you have installed more than one on your system. Grub is the system's bootloader. It is mandatory.

  • Thank you Stormlord, that was helpful and good knowledge. I have tried numerous time to boot into BIOS/SETUP. I'd turn my laptop on and immediately keep pressing F2 (to enter setup on dells), and I've also tried continuous press of F12 to jump into a manual boot menu choice for picking different devices. Neither one of those function buttons work for me or allow me into setup, like before. I have also used the Fn key, too, by hold it. Any suggestions, mates? – John Saul Jul 24 '16 at 4:11
  • I would recommend doing a search on the brand you have to get what ever information you need to get in to your BIOS settings if it's a Dell Inspiron 7537 their website should have this info. Each machine is different and may use different key commands, example my Dells use F-2 to access my BIOS – Rob Goss Jul 24 '16 at 15:18
1

Looks like your machine has a firmware bug, http://en.community.dell.com/support-forums/laptop/f/3518/t/19543161 , So if you still have warranty, use it And grub (or some other Linux bootloader like "lilo") is necessary for any Linux Distro to boot the system even if it is the main system on a machine. And grub has no problem with bios or does not create any obstacle to boot into bios.

0

Timing is critical on the use of the function keys when you've set the boot speed to "fast" instead of "normal" (or something like that). "Normal" gives you a few seconds to hit the correct function key, "fast" maybe a fraction of a second. Find out which key (probably F2) and keep trying -- hold it down just after power-up, hit it repeatedly as fast as you can at power-up, Had a Toshiba which I waited 6 sec, then hit F2. Remember, once in, change the boot speed to avoid such problems in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.