27

I bought the wireless adapter to use with a computer without internet access but I can't figure out how to install it with just a USB with the driver on it. I've read a few articles on how to install the driver but they all require me to have internet access and I don't have internet. I'm completely new to Ubuntu. If you can help that would be great. Thanks! Ps: I have the latest version of Ubuntu as of 7-5-16.

33

Please download this file on some other computer and transfer it to the desktop of the subject computer: https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master.zip Right-click it and select 'Extract Here.' Now, in a terminal:

cd ~/Desktop/rtl8812AU_8821AU_linux-master
make
sudo make install
sudo modprobe rtl8812au

Now that we have the wireless working correctly, we'll refine this a bit.

sudo apt-get update
sudo apt-get install dkms
cd ~/Desktop/rtl8812AU_8821AU_linux-master
sudo cp -R . /usr/src/rtl8812AU_8821AU_linux-1.0
sudo dkms add -m rtl8812AU_8821AU_linux -v 1.0
sudo dkms build -m rtl8812AU_8821AU_linux -v 1.0
sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0
15
  • 2
    Out of curiosity, what exactly do the "refine" steps accomplish? – Brannon Jan 18 '17 at 16:43
  • 6
    The refinement adds the dkms process. The driver will be compiled automatically for you if there is a newer linux-image installed. Highly recommended and thank you, @Eliah Kagan. – chili555 Jan 18 '17 at 21:21
  • 1
    actually - on ARMBIAN and on Debian-like systems - no need in "refine part" - it works fine after make install and modprobe – Alexey Vesnin Aug 2 '17 at 23:41
  • 1
    So awesome !!! This works even with Archer t4u AC1300 while the official drivers from the TP-Link don't compile. I tried downloading and building source from TPlink site from here: nl.tp-link.com/download/Archer-T4U_V2.html#Driver but that did not compile on my Ubuntu 17. But this GitHub source worked like a charm !!! – revolutionary Nov 19 '17 at 22:35
  • 1
    It turns out that the very same steps as above make my ac1300 work too! – Máté Wierdl Dec 2 '17 at 16:14
11

This driver can be installed from the official Ubuntu repositories by

sudo apt install rtl8812au-dkms
3
  • That's cool, but you have to have a working Internet connection first before using it. Kinda Catch-22. – user626528 Mar 9 '17 at 21:25
  • 1
    It is not a catch if you know how install packages offline. – Pilot6 Mar 9 '17 at 21:58
  • 2
    Also this doesn't install the same thing. T4U v2 doesn't work with this unfortunately. Compiling it from source and creating a dkms package does work like a charm though. – Gabor Lengyel Oct 26 '17 at 9:47
2

Works on Ubuntu 18.04.4 LTS with kernel head v5.3.xxx using this repo. which you will need to git clone into a local folder

https://github.com/EntropicEffect/rtl8822bu

git clone https://github.com/EntropicEffect/rtl8822bu

Make sure you have build-essentials and dkms

sudo apt-get install build-essential dkms

After cloning, cd into that folder and run

cd rtl8822bu
make
sudo make install
sudo modprobe 88x2bu

Then connect to your Wi-Fi (Hopefully, both 2.4GHz and 5GHz should be detectable now)

Next, follow these steps to refine the installation and for an automatic rebuild on Ubuntu kernel image updates

sudo dkms add .
sudo dkms install -m 88x2bu -v 1.1
2
  • 1
    this worked for me on Mint 20 - thank you! – BoDeX Aug 1 '20 at 16:55
  • This worked with ubuntu 20.10, thank you – Marc Steven Plotz Oct 23 '20 at 15:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.