13

I'm trying to install a dual boot (with Window 10) on my new XPS-15 (with a SSD 256Go).

Everything works well (following this tutorial) until I go on step "Installation type".

Where I can't select "Something else", and I already have the partition table but completely empty. I can't see any existing partition, or add new one.

enter image description here

2
  • 1
    as with many of the other similar questions: please make sure you install Ubuntu -the same way- as Windows. You can not mix UEFI and none-UEFI operating system. If you booted straight into Ubuntu you are doing it wrong. You need to boot from your BIOS using UEFI.
    – Rinzwind
    Jul 23 '16 at 20:08
  • 2
    @Rinzwind, I also try to reboot from Window10 using the reboot option, and selecting UEFI USB key. But same result :/
    – Arthur
    Jul 23 '16 at 20:28
14

It's due to the XPS's PCIE M2 drive configuration that is not recognised by the installer. I came across the same issue, in most cases this can be fixed by going to the BIOS (F2/F12 on boot up) and changing the SATA setting to AHCI. Save these changes and then reboot your Ubuntu boot drive and retry the install.

If the issue is still prevalent then see Dell's full guidance below:

Add the following kernel argument at boot time: nvme_load=YES

Press 12 when you see the keyboard prompt:

Press Enter to select Language.
Press F6.
Press Esc.
Modify the boot option to add "nvme_load=YES" and remove "quiet splash ---"
Before:


After:


Press Enter.

You will now see the nvme drive available in the installer:

Controller: Nvme0
Port: N1
Partition: Px
0
1

To add to rjmd's answer above, in case you get GRUB menu instead of the "keyboard prompt (Figure 2)" you can not press F12 or F6 to get into boot option menu. You can also tell the difference if the menu is using ugly block fonts to the left instead of nice fonts in the center of the screen and the top of the screen will say GRUB.

In such scenario highlight "Install Ubuntu" in the menu and press "e". Then you can edit the boot options in the same way,

Modify the boot option to add "nvme_load=YES" and remove "quiet splash ---"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.