0

I have a Windows drive that went bad. 500GB. I need data off it.

I'm new to Linux, so using the GUI version, not command prompt.

I downloaded the ISO and created a USB bootable drive, and am running Ubuntu from that right now, on the All In One computer that has the drive that needs recovery.

It will not mount, but under "Drives" I can see the 7 different partitions, and select the primary one (labeled correctly) with the C drive and all the data that should be on it.

I'm currently creating a partition image, and I was hoping to be able to mount it back in and navigate through the files.

I'm not sure if this is the best way to do this, or not.

Windows will not boot. When booting to run a CHKDSK /f or /r, it is taking FOREVER.

Right now, during the partition image creation, I have 11,608 bad sectors and it is 1% complete. It does say that it has saved 4GB of data, and 510MB is unreadable.

It's only one folder that I need: C:\Photos

Is there a better way to recover or access only that directory?


Update: It jumped to 70% complete now, 340GB done, 339GB unreadable. Yikes. Says a total of 16,024 sectors are bad.

Will CHKDSK even possibly fix this? I find it hard to believe that the data is just "gone"


CHKDSK ran, but now I can't read the superblock.

  • If it said that virtually all of the data is unreadable, then it's gone. Backups, backups, backups. – psusi Jul 23 '16 at 23:20
  • Actually this is an all in one that was in the field and coming back to be synced with the office---so there are instances that a backup just hasn't occurred yet. All I need is about 5gig of data. The rest is all backed up. – Dan Jul 24 '16 at 0:37
  • 3
    Possible duplicate of Cannot mount some partitions – Andrea Lazzarotto Jul 24 '16 at 12:51
  • Check out the question linked above for an answer including how to make a reliable copy of the drive with ddrescue and reconstructing the NTFS file system. – Andrea Lazzarotto Jul 24 '16 at 12:52
0

Run the following in Ubuntu's terminal:

sudo mount /dev/sdxx /mnt
cd /mnt
for i in `find . -name *`
do
    if [[ -r $i ]]
    then
        echo "$i is ok!"
        cp -f "$i" "/path/to/different/disk/that/is/uncorrupted/"
    else
        echo "$i is not ok."

If it does say $i is not ok, you have no chance of recovering that folder.

| improve this answer | |
  • So, it is SDA, and the partition is 5. My external is SDC. Would this be correct, or am I missing something? sudo mount /dev/sda /mnt cd /mnt for i in find . -name * do if [[ -r $i ]] then echo "$i is ok!" cp -f "$i" "/dev/sdc/" else echo "$i is not ok." – Dan Jul 23 '16 at 20:34
  • Is SDA5 the disk with Photos? – fosslinux Jul 23 '16 at 20:45
  • Yes, that is the NTFS Windows C Drive partition. – Dan Jul 23 '16 at 20:55
  • FYI, I tried mounting the image file that was created, and got the same error message as when trying to mount the ACTUAL volume--so creating the image did nothing. – Dan Jul 23 '16 at 20:59
  • When I attempt to mount the image I get this error: Mount is denied because the NTFS volume is already exclusively opened. The volume may already be mounted.... etc. etc. – Dan Jul 23 '16 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.