4

I am Using ubuntu 16.04 on ASUS X555L. sound was working correctly but instantly it just not working.

I have try every possible solution given on internet but still blank .

My sound setting does not have any output device even my headphone is attached.

I have try speaker also but does not work.

here is some link that i already try:

Sound not working in Ubuntu 14.04LTS after upgrading from 13.10

Sound not working in Ubuntu 14.04LTS

Sound not working in Ubuntu 14.04 Sound not working after 12.04 install

Tried to install audio driver for ASUS P5K, now sound is not working Ubuntu Sound Problems Asus K52F

If any other option other than installing ubuntu again ?

  • Which Ubuntu version are you using? What is 16.x, 16.0, etc? Is it 16.04, or 16.10? – Pilot6 Jul 23 '16 at 11:52
  • 16.04 LTS version – Shubham Batra Jul 23 '16 at 13:30
  • Have you resolved thus @ShubhamBatra. I face similar issues on my Asus lappie as well. – crafter Oct 5 '16 at 14:00
5

Try this answer. Run these commands in the terminal:

sudo apt-get update && sudo apt-get upgrade
echo options snd-hda-intel model=auto | sudo tee -a /etc/modprobe.d/alsa-base.conf

Check all mutes and unmute them through:

sudo alsamixer

Then run:

shutdown -h now
  • worked like a charm on my HP 840 G1 – PhillipMwaniki Jul 14 '18 at 11:17
1
sudo apt-get purge pulseaudio
sudo apt-get clean && sudo apt-get autoremove

Reboot. Open a terminal again and type (ignore any errors with the rm command):

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
sudo apt-get install pulseaudio
1

You can try this:

sudo apt-get purge pulseaudio
sudo apt-get clean && sudo apt-get autoremove

reboot as:

sudo init 6

The open your terminal and:

sudo apt-get install pulseaudio
sudo gedit /etc/pulse/default.pa
load-module module-switch-on-port-available
sudo init 6

Plug your earphone and start some .mp3's

0

i was having the same problem and i had tried everything but couldn't able to resolved the problem then i figured out that it wasn't the driver causing the problem it was keyring password that i had provided so if you tried everything ,try to reset your keyring password to blank

Go to System/Preferences/Password and Encryption keys, right click the appropriate folder and click Change Password. Put in your old password and leave the new one blank. its worked for me , try it may works for you.

0

You can try this, worked for me:

sudo nano /etc/modprobe.d/alsa-base.conf

Now add the following line at the end of the file, or if model=generic change it to model=auto

options snd-hda-intel model=auto
  • This is essentially the same as the answer of Silas Miranda. Could you develop why you think your approach is better? – Marc Vanhoomissen Jun 3 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.