0

I tried a lot to make touchpad enable in Ubuntu 16.04.1. I reinstalled drivers, kernals, was using synclient(as a matter of fact it has never changed "TouchpadOff" option), dconf. The only thing that helped me is setting inside of BIOS(or in my case UEFI) touchpad option to "Basic".

But I've got dual booting Ubuntu-Win10 and using Windows with "Basic" option isn't satisfying.

So the question: how to enable touchpad without changing BIOS's options?

UPD:

Cannot set this option in synclient setting also:

 synclient | grep Touchpad
    TouchpadOff             = 2
 synclient Touchpadoff=0 
 synclient | grep Touchpad
    TouchpadOff             = 0
 synclient | grep Touchpad
    TouchpadOff             = 2

'xinput':

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device                         id=12   [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device                         id=13   [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HD WebCam                                 id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=16   [slave  keyboard (3)]

'xinput list-props':

Device 'PS/2 Synaptics TouchPad':
    Device Enabled (137):   1
    Coordinate Transformation Matrix (139): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (263): 0
    Device Accel Constant Deceleration (264):   1.000000
    Device Accel Adaptive Deceleration (265):   1.000000
    Device Accel Velocity Scaling (266):    10.000000
    Device Product ID (257):    2, 1
    Device Node (258):  "/dev/input/event9"
    Evdev Axis Inversion (267): 0, 0
    Evdev Axes Swap (269):  0
    Axis Labels (270):  "Rel X" (147), "Rel Y" (148)
    Button Labels (271):    "Button Left" (140), "Button Middle" (141), "Button Right" (142), "Button Wheel Up" (143), "Button Wheel Down" (144)
    Evdev Scrolling Distance (272): 0, 0, 0
    Evdev Middle Button Emulation (273):    0
    Evdev Middle Button Timeout (274):  50
    Evdev Third Button Emulation (275): 0
    Evdev Third Button Emulation Timeout (276): 1000
    Evdev Third Button Emulation Button (277):  3
    Evdev Third Button Emulation Threshold (278):   20
    Evdev Wheel Emulation (279):    0
    Evdev Wheel Emulation Axes (280):   0, 0, 4, 5
    Evdev Wheel Emulation Inertia (281):    10
    Evdev Wheel Emulation Timeout (282):    200
    Evdev Wheel Emulation Button (283): 4
    Evdev Drag Lock Buttons (284):  0
  • What is the touchpad, what is the Ubuntu version? – Pilot6 Jul 26 '16 at 13:36
  • @Pilot6 SYN1B81:01 06CB:7407 Touchpad – Al Prihodko Jul 26 '16 at 16:56
  • Try this askubuntu.com/a/632570/167850 – Pilot6 Jul 26 '16 at 18:17
  • @Pilot6 Okay, now my touchpad is working, but drivers are gone and no touchpad feature is working. I've already tried reinstalling them, but nothing changed – Al Prihodko Jul 26 '16 at 20:18
  • What drivers are you talking about? – Pilot6 Jul 26 '16 at 20:25
0

I have become extremely annoyed at the touchpad changing my cursor position as I try to type, so I've searched all over the internet just to try and disable it. I have Linux Mint 18 installed with kernel 4.4.0-45. I did the following to make it easy to toggle the touchpad state.

sudo apt-get install xinput

xinput -list

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse          id=11   [slave  pointer  (2)]
⎜   ↳ FTE1001:00 0B05:0101                      id=14   [slave  pointer  (2)]
  • Look for the id of the touchpad, in my case it's 14. I wrote a small shell script to turn the touchpad off and on.

  • TouchPad off:

    cd /usr/local/bin
    sudo nano touchpad-off

    #!/bin/bash
    xinput --set-prop 14 "Device Enabled" 0
    echo touchpad off
    
  • TouchPad on:

    sudo nano touchpad-on

    #!/bin/bash
    xinput --set-prop 14 "Device Enabled" 1
    echo touchpad on
    
  • Make the scripts executable with:

    chmod +x touchpad-off
    chmod +x touchpad-on
    

    Now you can easily toggle the touchpad state with touchpad-off and touchpad-on.

0

There is no approved answer, although the problem seems solved for the original poster. I think we should try to clean this up for users in the future who find this note.

I wonder if the libinput driver's upgrades are responsible for the improvement here, rather than synaptics driver. What does "synclient -l" return on the fixed system? If it says "Couldn't find synaptics properties" then we'll know the fix is coming from libinput. In Ubuntu 16.10, there are quite a few more laptop profiles included with libinput.

If it is synaptics, well, I'm baffled why this would improve.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.