4

So I was recently doing an Arch install and ended up formatting my HDD in the process with fdisk. I gave up on Arch and reinstalled Ubuntu 14.04. Now whenever I try and open my HDD in Nautilus I get an error 'This Location could not be displayed. You do not have permissions necessary to view the contents of "HDD".'

I can use sudo nautilus and am able to view the files just fine. I can also format and relabel it with sudo gnome-disks , but the issue is that is a pain to do and would rather just have access to it without being root. I've tried running sudo chmod -R ug+rw /media/kalenpw/HDD but that does not solve this issue.

All the answers I find about this issue are about folders that always require elevated permissions, but this is the entire drive I can't access so they don't apply

Thanks for the help.

  • What's the output of sudo LC_ALL=POSIX ls -ld "$HOME" /media/kalenpw/HDD? – David Foerster Jul 23 '16 at 14:42
6

You should change owners. Run this command:

sudo chown $USER: /media/$USER/HDD

where $USER will complete to your current Ubuntu user and HDD is the name of the partition in question

  • Awesome thanks a million that fixed it. I'll accept your answer in 7 minutes when it lets me – kalenpw Jul 22 '16 at 21:21
  • This is not a long-term fix. These permissions will be lost as soon as you unplug the drive, so you'll have to run this command again every time you plug the drive back in. – Cerin May 23 '17 at 17:28
  • At first you may have to run ls -l /media/$USER to find out which mount point your drive is located at. In this case, of course, it was known to be mounted at /media/$USER/HDD. Ultimately, you may even want to run chown -R instead of just chown. If there’s a lost+found directory on the drive, you can change it back to root using sudo chown -R root:root /media/$USER/HDD/lost+found. And, by the way, the wrong owner for the hard drive can happen, for example, if you formatted the drive using a live CD/DVD, where the user is 999 and that’s who the owner will be. – caw Feb 1 '18 at 13:21
0

After doing chown and chmod ... In default file manager like Nemo -> right click on the folder or click on the background in you are inside that folder already -> properties -> Permissions -> Apply Permissions to enclosed files OR make the owner able to "read and write"

  • This will only work if you have the permissions to write on all the files/directories within that directory. Would be better to simply add the -R option (for recursive) to the chown command since anyway OP is already in the terminal – derHugo Dec 21 '17 at 6:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.