It was working properly before, suddenly it stopped working. When I tried to open by clicking on its icon, but nothing happens.

As already here are many questions related to this, but none of them are working for me. I already checked this and this.

I uninstalled Chrome by following the instructions from How do I completely uninstall Google Chrome and Chromium?.

sudo apt-get purge google-chrome-stable
rm ~/.config/google-chrome/ -rf

Again I installed Chrome by:

sudo apt-get install google-chrome-stable

But the problem is still thesame.

When I enter google-chrome in terminal I get following error.

[12289:12323:0723/014456:ERROR:nss_util.cc(744)] Error initializing NSS with a persistent database (sql:/home/maddy/.pki/nssdb): libsoftokn3.so: cannot open shared object file: No such file or directory
[12289:12323:0723/014456:ERROR:nss_util.cc(212)] Error initializing NSS without a persistent database: NSS error code: -5925
[12289:12323:0723/014456:FATAL:nss_util.cc(214)] nss_error=-5925, os_error=0

2 Answers 2


Workaround (symlink the nss libraries into /usr/lib/nss):

sudo ln -st /usr/lib "$(uname -i)-linux-gnu/nss"

Source: Chromium Issue Tracker (with adaptations)

  • 2
    I've got same error on Debian Wheezy with chromium 37.0.2062.120-1~deb7u1, but symlinking (neither this nor x86_64-linux-gnu/nss directly) does not help, and neither does removing ~/.config/chromium Oct 29, 2016 at 0:33
  • 2
    I have the same problem on Debian Wheezy with chromium 37, after upgrading libnss3 to version 3.26-1. Jul 15, 2017 at 18:32

I just recently had a Chrome browser issue. Just to note. It was Not fun to fix. My issue was a Chrome / Remote Desktop issue and I had login issues and video issues as well, but here are some things you may try.

I saw where users have tried linking the files to a library.

For the Wheezy user I’d suggest just down grading your libnss3 if possible.

If you have firefox, thunderbird or seamonkey you might try linking to those. You can use these commands to help you find other packages using that library. As you try each link, and if it does not work , remove it and go onto the next one.

Search for files

locate libsoftokn3.so | xargs ls -l
locate libsoftokn3.so | xargs dpkg -S
locate libsoftokn3.so | xargs file

With my issue Chrome process got hung and my video got messed up some how. That did not seem like the root cause though. I could not get Chrome to launch properly or get chrome-remote-desktop to work any longer.

I think besides having the latest Stable Chrome release you may also need to update the NSS package libnss3-1d and sqlite3.

On Ubuntu site there are actually specific fixes for NSS being linked to the correct libraries. Search NSS libnss3-1d. You’d need to search your specific distro and info on the package to see if it mentions fixing link issues to libraries.

You also want to make sure .pki and chrome are owned by you and not root. Make sure .pki directory is not owned by root. I think it sounds like a linking to library issue though.

Most articles I searched point to:
A library link issue
NSS package issues

I also had to do a system search for my specific video / graphics and update those packages.
I’m not sure what exactly fixed the issue, but saw the post so I thought I’d throw you more things to check out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .