1

I use USB Modem (Mobile Broadband) to connect to the internet. Prior to Ubuntu 16.04, there used to be a connection setting where you can set a Network-Type (aka gsm.network-type property) through either the GUI Editor or the command-line (you can see the gsm.network-type property there).

However, this setting seems to have been removed since 16.04, its no longer visible in the GUI or configurable in the CLI. My problem is that the mobile broadband that I use works well only in "3G Only" (aka UMTS) mode, otherwise there are frequent disconnections in the default auto mode. So, how do I enable that setting in this new version of network-manager? Is there any workaround to it?

  • Tell us a bit more with lsusb about what mobile broadband modem you are using? – Serge Stroobandt Dec 18 '16 at 3:32
1

i don't know to do it using gui on ubuntu 16.04 .

locate following location with root access etc/NetworkManager/system-connections/ and then find and edit your network profile using nano editor (nano dialog_gsm) add following code to [gsm] sectoin

network-type=0

1

You can use modem-manager , to install it , open the terminal and type the following command:

sudo apt-get update
sudo apt-get install modem-manager-gui
  • I already have it installed. But how does it help? I couldn't see any option for enabling 3g-only or UMTS mode. – Prahlad Yeri Jul 22 '16 at 20:58
  • @PrahladYeri You said the answer didn't help. Then how and why did you accept this answer? I too have modem manager gui installed and it doesn't help a bit ! – Anwar Jul 15 '17 at 7:27
  • @Anwar When I accepted, this was the only answer available and I was in a hurry! I don't remember exactly what worked (as this was a long time ago and my ISP doesn't need a 3g-only connection setting any more). More likely, it was a direct configuration file change as specified in this other answer: askubuntu.com/a/802731/49938 – Prahlad Yeri Jul 15 '17 at 7:50
  • You don't need to feel compelled to accept an answer even if that's wrong. If you do so, it will harm the site – Anwar Jul 15 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.