0

I was doing a lot of system installs such as GL, cmake etc. I finished installing and I am unable to reboot Ubuntu 14.04 LTS. I ran the hardware diagnostics and no errors were found. It starts and you see the violet screen and it just hangs. I did try to access the GRUB menu by pushing the shift button but it does not seem to appear. Instead it goes straight to hardware diagnostics. I have a Dell Vostro 3800 desktop and no Windows is installed on this machine. It is a pure Linux desktop.

I saw this boot repair software - https://sourceforge.net/p/boot-repair/home/Home/

Do I need to write this to a CD and then try to boot from CD ROM drive ?

  • make a live usb from another pc and try fixing grub – Brij Raj Kishore Jul 22 '16 at 19:04
  • @BrijRajKishore - is the data safe ? – gansub Jul 22 '16 at 19:05
  • yes, unless you delete it. – Brij Raj Kishore Jul 22 '16 at 19:07
  • @BrijRajKishore - after creating a live usb of Ubuntu 14.04 I insert the usb into the Ubuntu desktop and then what ? – gansub Jul 22 '16 at 19:08
  • Check whether the storage is not full. It become unable to start when your root partition/ directory gets full – Brij Raj Kishore Jul 22 '16 at 19:37
2

Note: It is mainly for grub rescue for the systems having multiple OS but it worked for me. It Needs an active Internet Connection Run Commands :

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get update

sudo update-grub

sudo apt-get install -y boot-repair && boot-repair

launch Boot-Repair from either :

the Dash (the Ubuntu logo at the top-left of the screen)

or by typing 'boot-repair' in a terminal

Then click the "Recommended repair" button. When repair is finished, note the URL (paste.ubuntu.com/XXXXX) that appeared on a paper, then reboot and check if you recovered access to your OS.

If the repair did not succeed, indicate the URL to people who help you by email or forum. Hope It Helps.

Source - : https://help.ubuntu.com/community/Boot-Repair & https://www.youtube.com/watch?v=mFEg4Hbw2kk

| improve this answer | |
  • I get a no boot device available . It looks like a hardware issue – gansub Jul 23 '16 at 0:55
  • What is the error can you send it with screen shot or just click it with cell phone and send – Brij Raj Kishore Jul 23 '16 at 12:28
  • Page Not Found Link – Brij Raj Kishore Jul 23 '16 at 12:37
  • it says boot device not available. SATA 1 available SATA not avaialb.e Press F1 to boot – gansub Jul 23 '16 at 12:43
  • This might be helpful. Please ensure in bios that your hard drive is detected . See : tomsguide.com/forum/56993-35-what-boot-device-mean – Brij Raj Kishore Jul 23 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.