Okay so, I apologize in advance if the solution is plainly and painfully obvious, as I am a complete Ubuntu noob.

To keep things short, basically: longtime Mac user, disgruntled with Apple hardware of late, had to upgrade from my 2008 MacBook so I went with a PC laptop, however after a couple of months of use it is now a certainty for me that Windows and I will never see eye to eye.

So I downloaded Ubuntu 16, used Rufus to turn the iso into a bootable flash drive. All pretty painless up to this point.

I also feel like I should mention that the laptop in question is an MSI GS-60 6QE Ghost Pro (I believe it is the 2015 model, not the similarly named and more recent 4K one) which has no optical drive (hence the need for a flash drive for the install). Came with no system installed and originally I installed Windows 7 on it, however I have uninstalled it from the hard drive (the laptop has an SSD/HDD combo and I installed 7 on the SSD with the user and temp folders moved to the HDD).

Which brings me to the problem at hand. The laptop's BIOS offers three boot options: UEFI, UEFI-CSM and Legacy. I have now tried to launch Ubuntu using all three configurations and none of them work. Well, that's not exactly true, every time the flash drive does boot, and I see the launch menu, however whether I try to either "Try Ubuntu without installing" or "Install Ubuntu" it invariably gets stuck in the exact same way.

More precisely, I get the Ubuntu logo, with the five marbles underneath, the five marbles fill up with orange, then the first of the five fills up with white again, the laptop's power on button briefly flashes from its normal red to blue and back to red again, and then the screen gets stuck with the first two marbles white and the last three in orange and it never goes past that point. Exact same sequence every time and I tried it about five times already. And it doesn't pick up from there, I tried to leave it for about ten minutes but it doesn't move.

I'm pretty sure it has to do with the boot mode but, I'm not sure what else I can do if none of the boot modes on my computer actually work.

Anyways, if you have any idea of what the problem might be, any help is appreciated.



  • It's probably an issue with the gpu. Try booting up with the live usb again, only this time, when you get to the menu, hit f6. A grey menu should appear. Select nomodeset. Then select "Try Ubuntu" and see what happens. If that doesn't work, try acpi=off. Jul 22, 2016 at 17:09
  • Hi Alcuin, thanks a lot for the superfast answer. First option got me to an admitedly pretty but completely empty desktop with only the cursor, however trying again with acpi=off did manage to boot, seemingly correctly, but this time I have no mouse cursor (no matter how much I wiggle my finger around on the touchpad). Perhaps I need to enable both options?
    – Octaedre
    Jul 22, 2016 at 17:22
  • Try again with the acpi=off option (the one that left you without a mouse). When you get to the desktop, hit ctrl+alt+t and enter sudo modprobe -r psmouse && sudo modprobe psmouse. Jul 22, 2016 at 17:28
  • Got the command prompt to pop up, however when I try to type in anything no actual letters get typed... The white square stops blinking when I try to type in letters though, I don't know if that helps.
    – Octaedre
    Jul 22, 2016 at 17:35
  • I'm afraid I'm out of ideas. If you can do both nomodeset and acpi=off at bootup, it's worth a try. Otherwise someone with more expertise than I have will need to step in. Jul 22, 2016 at 17:41

2 Answers 2


Okay well nevermind guys I got the answer I needed after even more crazy things happened. In the end I got the dude at the customer service to tell me that the computer that I have is basically useless without Windows 10 and that all the problems that I've been having basically stem from me not having installed that OS in the first place, and that until I install it l'll probably only run into problems using it with any other OSes so. Yeah, if someone wants an overpriced locked-down laptop that will only run Windows 10 you know where to find me.


I have an MSI GE62 6QD and I have Linux Mint 18 Running almost flawlessly on it. Given that LM and Ubuntu are so closely related this should help.

First, I had to go through and disable things in the UEFI: Secure Boot, VMWare, and Speed Step.

Second, at the GRUB menu when booting from a live media I had to edit the boot to force the machine into software rendering with "nomodeset" and "nouveau.blacklist=1." I also deleted "quite splash." This was the only way I could get it to boot fully.

Then I did a normal install. Upon reboot the system worked and was using Nouveau as the video driver.

To use the Nvidia driver I had to update the kernal to 4.4.0-28 then add the PPA to use nvidia-367. If I didn't update the kernal or use an earlier driver, the system would crash. I also added the intel microcode driver.

After this, I went back to the UEFI and turned everything back on. The computer runs smoothly now.

The steelseries keyboard doesn't have Linux drivers and some of the MSI hot keys don't work as labeled. (gearshift comes to mind)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.