I upgraded to 16.04 from 15.10 and every things was good. After installing new updates, launcher, menus and top panel disappear when I login.

I tried this commands:

dconf reset -f /org/compiz/
setsid unity

Also used ccsm command and checked that Unity plugins is enabled. Still problem exists.

How to solve this?

4 Answers 4


After spending so much times and searching, I tested almost all the solutions on the internet.

  1. Problems after upgrading to 14.04 (only background and pointer after login)
  2. Launcher disappeared
  3. Ubuntu 16.04 no menu bar or launcher - help!

But problem didn't solve. Totally the only solution which worked for me was follwing this instruction:

  1. open /usr/bin/ and run gnome-terminal.real
  2. run adduser newuser to create a new user
  3. run kill -9 -1 to logout
  4. login using newuser
  5. do #1 again
  6. run su olduser and enter your password
  7. run mv /home/olduser /home/olduser_backup
  8. run mkdir /home/olduser
  9. run chown olduser:olduser /home/olduser
  10. run reboot
  11. login using olduser

Totally you can delete newuser by running these commands:

sudo deluser newuser
sudo rm /home/newuser -rf

After updating my Ubuntu 16.04 I experienced the same issue. I solved it by removing the /home/your_username/.config/compiz-1/compizconfig directory:

rm -rf /home/your_username/.config/compiz-1/compizconfig

After which I logged out and in.

The directory originally contained the files:

  • config
  • Default.ini
  • done_upgrades

After removing the directory and logging in and out, it now contains the files:

  • config
  • done_upgrades

The done_upgrades file has not changed and the config file has changed from:

backend = ini
profile = 
integration = true
plugin_list_autosort = true


profile = unity-lowgfx

The removed Default.ini contained:

s0_outputs = 1488x858+0+0;

So I guess the issue was caused by one of these files, but I know nothing about compiz, so I cannot tell what could have caused it.


If you get this problem when running 16.04 under VirtualBox (like I did) none of these fixes work but changing the machine settings to remove 3D acceleration will bring the unity desktop back.

  • I got the problem running 16.04 under VirtualBox, and my solution definitely worked for me. Aug 23, 2016 at 20:05

After my recent 16.04 update, I had this same problem. What finally fied it for me after trying many solutions that did not work:

  1. chown user.user ~/.config/dconf/user (change owner and group of user file)
  2. kill -9 -1 (to log outof session)
  3. log back in and bar has returned

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .