2

This question already has an answer here:

I downloaded an installer from here and run eclipse-inst. It showed a dialog to select an IDE to install, I selected Java and installed it in /root/java, then it showed me a button to launch it... I launched it and it opened the IDE, but when I closed the IDE, I couldn't find it anywhere in my computer using search. I also hadn't access to /root/

How can I uninstall it?

How could I install such programs correctly? Did I make a mistake?

marked as duplicate by Elder Geek, Yaron, Charles Green, Eric Carvalho, Mark Kirby Oct 3 '17 at 18:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Fabby this question need an answer for correct usage of eclipse installer. however they are similar in the end – Ahmad Jul 23 '16 at 13:03
  • @Ahmad: then go and edit the original! You get rep for that too! ;-) – Fabby Jul 23 '16 at 13:08
2

If you use installer to install the Eclipse, give it an appropriate directory like /opt. After installation you have access to this directory and you can run Eclipse located in the installed directory.

In fact, you could directly download and extract your desired IDE without using the installer.

If you want to give the program a shortcut in launcher follow the instructions in this answer.

0

You can follow the steps detailed in this answer

In step 6, install the latest version of openjdk (either 7 or 8) instead of openjdk-6-jdk package i.e

sudo apt-get install openjdk-7-jdk for OpenJDK: JDK 7 or sudo apt-get install openjdk-8-jdk for OpenJDK: JDK 8

0

I had the same problem and just resolved it. It seems that eclipse is not installing to the pc. but first time you run it, yes it seems to be installing to the pc. (definitely it is stored in somewhere) To run eclipse you need to go to the folder that you extract the eclipse zip file and then click on the eclipse application. then window appear and asked to select a workspace, (if you select the checkbox "use this as a default and do not ask again" from next time on wards eclipse just loaded to the default workspace) you just have to provide a folder path and click on OK button. that will solve your problem :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.