I'm trying to add a BlueParrott B-250XT+ bluetooth headset on a Thinkpad X230 tablet running Ubuntu 16.04 with its hardware bluetooth adapter.

The adapter works - meaning it detects/sees the headset. However, when connecting to the headset it initially connects, then this error pops up:

Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol Not available

Afterwards, the Headset disconnects and future connections are impossible - this is some sort of failure/error that causes the bluetooth to be unresponsive afterwards.

I have Pulseaudio installed and I have bluetooth set to load after X11 (this is what got me this far - to the point I can connect). But, as mentioned, the device gets dumped shortly after connection.

  • same problem here. I have a fresh xubuntu installation on my dell latitude e6410 laptop. Trying to connect to JBL Charge3 speaker. The device was paired, but i can connect only to serial port. When Try to connect to audio sink or headset I get Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not available Jul 22, 2016 at 12:10
  • I advice to try on a (live) Ubuntu 15.10 first, so that you can have an idea if the problem is in the BT stack version. Ubuntu 16.04 had a bluetooth stack update which significantly broke BT functionality.
    – Marcus
    Aug 8, 2016 at 20:45
  • That is a really good idea! I will try some live CDs when I have the time. Thanks,
    – psedach
    Aug 18, 2016 at 19:52
  • 1
    Note that on ArchLinux the package to install is named pulseaudio-bluetooth instead of pulseaudio-module-bluetooth. Just leaving a note here since this is the first result that comes up in the Google search.
    – xji
    Mar 3, 2018 at 20:13

2 Answers 2


The solution from this article worked for me:

sudo apt-get install pulseaudio-module-bluetooth
pactl load-module module-bluetooth-discover

Then delete the device from bluetooth devices and pair it again.

If it works, you can consider adding the second command to your startup settings, so that you don't have to run it again after every reboot.

If it doesn't work, try restarting pulseaudio:

pulseaudio -k
pulseaudio -D
  • 39
    Thanks for the tip - I get a message 'Failure: Module initialization failed' when I do step 2 so it doesn't work for me yet.
    – psedach
    Aug 4, 2016 at 2:24
  • 6
    Worked for me, but I need to do that every time I reboot...
    – Korri
    Nov 7, 2016 at 20:24
  • 1
    Worked on Xubuntu 16.04 on Lenovo G580. If you are hearing the sound through the laptop speakers after successfully pairing it, try changing the profile at Volume Control -> Configuration -> Built-in Audio.
    – lepe
    Jan 2, 2017 at 9:58
  • 8
    @psedach, be aware that message will show if one attempts to load the module when it's already loaded. You can test whether it's loaded with pactl list | grep module-bluetooth-discover. Nov 24, 2017 at 9:17
  • 2
    My default pulse configuration file /etc/pulse/default.pa there was already the configuration line in there. .ifexists module-bluetooth-discover.so \n load-module module-bluetooth-discover \n .endif On the next startup, it worked out-of-the-box. (\n added to symbolise linebreaks that were there) Oct 3, 2018 at 11:03

What did work for me was this: (as pointed above by Sebastian Widz)

$ sudo apt-get purge pulseaudio  
$ rm ~/.config/pulse && sudo killall pulseaudio  
$ sudo apt-get install pulseaudio  
$ pulseaudio --start

The above to ensure pulse is working first.
Then, this one, which is a bit weird that doesn't come by default with pulseaudio itself:

$ sudo apt-get install pulseaudio-module-bluetooth  
$ pactl load-module module-bluetooth-discover  

A bit redundant I know, but these were the exact steps that worked for me 10 minutes ago.
But OK, at least it works now :)

  • Thanks, this worked for me! It seems that sometime pulse's configs get messed up preventing connection to my BT headsets.
    – ksg91
    Mar 8, 2021 at 6:31
  • Worked for me in Xubuntu 21.10.
    – user107425
    Feb 19, 2022 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .