2

I'm trying for several hours, I'm getting this :

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-UWeLSq-build/
Command '['/bin/sh', '/tmp/tmpkajulyzd', 'python2',
 '/home/adi/Eclipse-Workspace/cumulus/parts/cumulus/install/usr/bin/pip2',
 'install', '--global-option=build_ext', 
 '--global-option=-I/home/adi/Eclipse-Workspace/cumulus/parts/cumulus/install/usr/include/python2.7',
 '--target', '/home/adi/Eclipse-Workspace/cumulus/parts/cumulus/install/usr/lib/python2.7/site-packages',
 '.']' returned non-zero exit status 1

I have read the guides, I have looked at examples the only example with python beeing a small script with no need of dependencies.

Edit, content of the yaml:

name: cumulus
version: "1.0.0"
summary: Test summary
description: Test description
confinement: devmode

apps:
  cumulus:
    command: python2 cumulus

parts:
  cumulus:
    plugin: python2
    source: https://github.com/kd8bny/cumulus.git
    source-type: git
7
  • Can you post your snapcraft.yaml file somewhere? – dholbach Jul 22 '16 at 6:13
  • Hi and thanks, I updated my question with the content of the yaml file. as you can see it's the basic example. – adi Jul 26 '16 at 14:04
  • You need to add stage-packages: [python-distutils-extra], but then it fails with this: paste.ubuntu.com/21116440 – dholbach Jul 27 '16 at 8:25
  • :| python2: can't open file '/home/adi/Desktop/cumulus/parts/cumulus/install/usr/bin/pip2': [Errno 2] No such file or directory plus same error like last time. – adi Jul 27 '16 at 9:03
  • 1
    Hey man, just wanted you to know that the error was caused by existence of another version of pip which I installed using pip install -U pip setuptools command, now I got the same error as you. Thanks – adi Jul 27 '16 at 13:12
2

The issue was that I had two versions of pip:

  • One installed using sudo apt-get python-pip
  • One installed using pip install -U pip setuptools

Apparently snapcraft doesn't know from where to copy it when the second command is used to install another version of pip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.