1

I recently upgraded my 900x3a notebook from 14.04 -> 16.04.

Since then the touchpad performance is bad. The pointer will sometimes freeze or execute ungiven commands. When this happens I often see an increase in CPU usage. First I thought its a xserver problem but when I add an USB mouse these problems dont occur (with the mouse, still occur with the touchpad).

I also tried a lubuntu 16.04 live USB stick and was able to reproduce the problem.

The linked solution posted in Mouse pointer (touchpad) getting stuck often in 12.04

(CTRL+ALT+F2) and back (CTRL+ALT+F7) works as a temporary fix if the problem occurs but does not solve this as the problem just will reoccur. Should I report this as a bug?

I changed to ´libinput´ as suggested below and both frequency and severeness of the problem decreased. As requested here is the input of the xinput command:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ WebCam SC-13HDL10931N                     id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

The problem might be connected to the use of scrolling or other multifinger commands but I have not had a sufficient number of incidents to be sure.

Do you have any suggestions how to fix this or what to try next?

Thanks!

  • Please edit your question and add output of xinput terminal command. – Pilot6 Aug 2 '16 at 14:55
  • What is the kernel version uname -a? – Pilot6 Aug 2 '16 at 15:07
  • ´4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:06:14 UTC 2016 i686 i686 i686 GNU/Linux´ – El Burro Aug 2 '16 at 15:09
  • I installed LUBUNTU 16.10 in my LAPTOP DELL LATITUDE E6400 using Unetbootin to create the USB KEY used for the installation. The live version was OK, but after installing both mouse and touch pad were not working. I deleted the LUBUNTU installation and made a new one installation using shell to transfer lubuntu-16.10-desktop-amd64.iso to USB KEY. The new installation is working perfectly. From my point of view I think is better to avoid Unetbootin to create USB KEY. – El condor pasa Feb 11 '17 at 15:48
1

I suggest installing libinput. It works better in 16.04, than the old xorg-synaptics.

Install it by

sudo apt install xserver-xorg-input-libinput

Tapping is disabled by default. If you need this feature, you can enable it by adding

Option "Tapping" "True"

to the touchpad section of /usr/share/X11/xorg.conf.d/90-libinput.conf

  • I tried this and both frequency and severeness of the lags has decreased but did not vanish. – El Burro Aug 2 '16 at 14:53
  • After working for two days with this suggested solution the result is so much better that I will mark it as solved. Thank you :) – El Burro Aug 4 '16 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.