4

I'm not to familiar with Ubuntu, but I need to install the previous version because the current one has some bugs.

I went to here and found the version that I wanted: http://www.ubuntuupdates.org/package/google_chrome/stable/main/base/google-chrome-stable

Naturally, I tried to install it with apt-get: sudo apt-get install google-chrome-stable=51.0.2704.106-1

However, after running that command, I received this message and I tried Googling the issue and couldn't find a solution:

ubuntu@box533:~$ sudo apt-get install google-chrome-stable=51.0.2704.106-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '51.0.2704.106-1' for 'google-chrome-stable' was not found
ubuntu@box533:~$ 

How can I install an older version of Google Chrome via command line?

0

You cannot unless you could grab a copy of the version 51 of Google Chrome. Because Google never allow downloading of older releases and what you found on ubuntuupdates.org is just a reference. They do not host any binary files.

Your best bet is to search in some non-techy friend who doesn't update browsers for years (old grandma's pc can help here too) and see if they have a 51.

0

I managed to install older Chrome very easy. I first installed latest Chrome (v64). Then installed older v61 version from here:

https://www.ubuntuupdates.org/package/core/artful/universe/base/chromium-browser

with this command:

sudo dpkg -i --ignore-depends=chromium-codecs-ffmpeg-extra chromium-browser_61.0.3163.100-0ubuntu1.1378_amd64.deb 

also, make sure to block updates like this:

sudo apt-mark hold chromium-browser

You just run it as dkpg -i on your dist and see if some dep fail.. and if it does, your chance is to list it with --ignore-depends= flag and see if it goes through.

I've used this on my Ubuntu 16.04x64 because on newer versions > v64 you can't use .dev for staging for web dev purposes, see details here:

https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/

output from cli is:

krex@krex-N752VX:~/Desktop$ sudo dpkg  -i --ignore-depends=chromium-codecs-ffmpeg-extra chromium-browser_61.0.3163.100-0ubuntu1.1378_amd64.deb
dpkg: warning: downgrading chromium-browser from 64.0.3282.140-0ubuntu0.16.04.1 to 61.0.3163.100-0ubuntu1.1378
(Reading database ... 686845 files and directories currently installed.)
Preparing to unpack chromium-browser_61.0.3163.100-0ubuntu1.1378_amd64.deb ...
Unpacking chromium-browser (61.0.3163.100-0ubuntu1.1378) over (64.0.3282.140-0ubuntu0.16.04.1) ...
Setting up chromium-browser (61.0.3163.100-0ubuntu1.1378) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.