1

I have installed the latest iscan driver from Epson, but the scanning function in Ubuntu 16.04 is still not working. Does anyone have a solution? SOLVED

  • 1
    Instead of adding "solved" to the question's title, you should post how you solved it as a separate answer. After 48 hours you may mark your own answer as accepted by clicking the gray check mark beside it which changes its color to green. – karel Jul 21 '16 at 5:46
2

Luckily, I just found a solution based on this instruction: https://help.ubuntu.com/community/sane and problem in installing Epson Scanner in Lubuntu 15.10 (64bits)

What I did:

  • Installed some packages:

    sudo apt-get install sane sane-utils libsane-extras xsane  
    
  • Edit /etc/sane.d/dll.conf file as follows:

    1. Add epkowa because in my case it is not in the list or remove # before epkowa if it is exist
    2. Add # before epson2 to avoid conflict with epkowa

There is a still message about permission denied when I run xsane, however xsane scanning is working well. The solution is by changing folder permission and any folder/file inside /home/username/.sane to 755 rwxr xr x OR You may try run xsane as root - sudo xsane.

And for iscan, it is also working perfectly without changing any permission.

0

From man 7 sane:

   If  your  device  isn't  found  but  you  know  that  it  is  supported,  make  sure  that  it is detected by your operating system. For SCSI and USB scanners, use the
   sane-find-scanner tool (see sane-find-scanner(1) for details). It prints one line for each scanner it has detected and some comments (#).  If  sane-find-scanner  finds
   your  scanner  only  as  root but not as normal user, the permissions for the device files are not adjusted correctly. If the scanner isn't found at all, the operating
   system hasn't detected it and may need some help. Depending on the type of your scanner, read sane-usb(5) or sane-scsi(5).  If your scanner (or other  device)  is  not
   connected over the SCSI bus or USB, read the backend's manual page for details on how to set it up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.