2

This question already has an answer here:

I have dual os (not sure if it should be called dual since it's not on the same hdd) Everytime after I switched from ubuntu back to windows 7, the time always changes. Suppose the time is 8pm now but the time would be approx 4am that each time I have to udpate the time in order for it to get to the right time.

Can someone please give me a hand?

marked as duplicate by mikewhatever, waltinator, Pilot6, David Foerster, Luís de Sousa Jul 21 '16 at 14:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

It's not an unknown issue. The "issue" stems from the fact that Linux uses "UTC" (Grenwich Mean Time or GMT, also referred to as Zulu) whereas Windows uses your local time to set the system master time.

You can fix this from Windows or Linux based on these instructions at webupd8.

From Windows, first create WindowsTimeFixUTC.reg and apply it by double clicking it:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=dword:00000001

And then from a Command Prompt as Administrator:

>sc config w32time start= disabled
  • 2
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Karl Richter Jul 21 '16 at 12:27
  • 1
    I'll keep that in mind, but don't think that warranted a -1 vote. but now i know ... btw, the link is a perma link, to an archived article [see the date in the link] soit won't be going dark anytime soon but the reason you stated does make sense, is very valid so I apologize. – UbuntuJason Jul 23 '16 at 2:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.