Everything was working correctly until I updated my Ubuntu 16.04 to the latest kernel, etc. running a dist-upgrade.

After the update, my workspaces stopped working even though I tried to check, uncheck, reinstall unity-control-center, etc. There are also other settings that stopped working correctly, such as the Launcher placement (Shows on both my monitor while the setting is set to only show on my primary), Sticky edges. All in all, there might be other settings that are not working correctly, as I haven't tested them all.

I even reinstall Ubuntu 16.04 on top of the other, which temporarily fix the issue. But as soon as I made the dist-upgrade on the fresh reinstall the same settings , as above, stop working again.

Any idea why some of the settings suddenly stopped working?

If I run this command:

dconf read /org/compiz/profiles/unity/plugins/unityshell/num-launchers

Will return the right value, either 1 (if I set launcher on one screen) or 0 (if I set the launcher on all screens).

dconf read /org/compiz/profiles/unity/plugins/core/hsize

dconf read /org/compiz/profiles/unity/plugins/core/vsize

Both return 2 (if I tick Enable Workspaces) or 1 (if I untick Enable Workspaces)

So I'm guessing the settings actually get changed, but they are getting ignored for some reason?

Edit: I've decided to retry to upgrade packages by packages, to pinpoint which package was causing the issue. The issue appeared after updating the Unity packages.

I also tried the answer below but I still can't use workspaces, launcher placement and sticky edges sine they are being ignored.

  • That is odd! Thanks for trying. If even a newly created user has the same problem, we can exclude a local issue. Removed my answer. – Jacob Vlijm Jul 23 '16 at 7:44
  • This is getting weird. I untick Enable Workspace, deleted the ~/.config entirely, logged out and back in and now once I tick Enable Workspace it is working (for both user)... but as for the other setting such as Launcher placement, sticky edge, no luck. Could it be related to the video card driver ? – Alexandre Villeneuve Jul 23 '16 at 18:02
  • I can hardly imagine, but you could try and switch to propietry driver (or generic, depending on what you are currently using), restart and see what happens. – Jacob Vlijm Jul 23 '16 at 18:09
  • Finally Workspaces aren't fixed. I always have workspaces on even when I untick the Enable Workspaces – Alexandre Villeneuve Jul 23 '16 at 18:31
  • Definitely something with the updated packages, I've tried reinstall Ubuntu 16.04.1 64bit and the problem persists, even on the USB Try Ubuntu the problem is there. So I reinstalled a fresh 16.04 64bit (without updates) and the problem was gone. I could setup workspaces, launcher placement, sticky edge were all working like it was set. As soon as I run an update command then reboot. The problem comes back. – Alexandre Villeneuve Jul 24 '16 at 21:22

When verifying About this computer, Graphics was not detecting my graphic card and was showing - Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits) (I had the X.Org X server nouveau display driver installed).

So I switched the driver from the X.Org X server to the NVIDIA binary driver (version 361.42) from Software & Updates > Additional drivers.

After a reboot, I re-verified About this computer, Graphics detecting my card (GeForce GTX 970M/PCIe/SSE2) and every Unity settings started working properly.

| improve this answer | |

I experienced the same issue and don't really know much about Ubuntu but doing the opposite of this here, fixed it for me:

Enable Low Graphics Mode

So, to expand a little on the solution. Here are the original steps (from the link above) to enable the low graphics mode. You would instead disable it by setting UNITY_LOW_GFX_MODE=0.

There is an environment variable you can set, UNITY_LOW_GFX_MODE


UNITY_LOW_GFX_MODE=1 unity should replace your existing session with the "low graphics mode" >desktop.

If for some reason you want to make it permanent

For your user:

Add the line

export UNITY_LOW_GFX_MODE=1 to the file ~/.xprofile (create one, if it doesn't exist). Or globally:

Create a file /etc/X11/Xsession.d/99force-llvm and add above line (requires root permissions, see this answer about how to create a file as >root).

You can set this globally in one step by running the following line >inside a terminal: echo "export UNITY_LOW_GFX_MODE=1" | sudo tee >/etc/X11/Xsession.d/99force-llvm

| improve this answer | |
  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Karl Richter Jul 27 '16 at 9:25
  • Thanks for the heads up - makes perfect sense. I've edited my answer. – Thomas Sering Jul 27 '16 at 10:43
  • Thanks for the answer, but it doesn't do anything for me. I still have none of the above settings working correctly. – Alexandre Villeneuve Sep 7 '16 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.