When I was using Maverick, it was possible to switch the input method from a UIM indicator applet. Now that I have upgraded to Oneiric, I can't seem to switch the input method even when I open uim-im-switcher-gtk. This is necessary for me because I need to be able to switch back and forth between English and Tibetan and the keyboard shortcuts don't seem to work until after I've changed the input method from the panel first. Is there some way to get a UIM indicator on the Unity panel? This is a major regression for me and makes it impossible to do certain kinds of work in Ubuntu.


There is an indicator in oneiric, but it is part of the "application-indicator", and pulls settings from gnome-settings-daemon.

So, to enable it, add the input method via System Settings->Keyboard Layout, which is the gnome-settings-daemon config tool for this purpose. You'll get an indicator in the Unity launcher (but not the greeter) with a dropdown of configured input methods. Also, in that settings module, there is an "Options" button that brings you to a number of settings, including the keybinding for changing layout.

I just checked there there is a Tibetan layout available, and that it works. At least, it looks like it works to someone who can't read Tibetan. ;-)

  • Thanks, zanfur, that is useful, but still not exactly what I am looking for. That particular Tibetan keyboard layout is a bit alien to me. Is it possible to install and/or create other, 3rd-party layouts? For anyone who might be reading this and is familiar with Tibetan, are there Wylie or extended Wylie layouts available via this method? – James Nov 18 '11 at 10:21

So I figured out how to get UIM in the Unity panel for anyone who wants to do it. First, if you haven't already, install dconf editor. Open it and go to desktop > gnome > unity > panel. In the systray-whitelist "Value" field, add a new item 'uim-toolbar-gtk-systray' between apostrophes. My systray-whitelist looks like this: ['JavaEmbeddedFrame', 'Wine', 'scp-dbus-service', 'Update-notifier', 'uim-toolbar-gtk-systray']. Now restart Unity by logging out and logging back in. Enter the command: uim-toolbar-gtk-systray. You should also add this same command to your Startup Applications.

In my dark panel, the UIM menu looks like rubbish. For some reason it's all squished into one small area and the background is light. But at least it works.


In Natty, Ubuntu switched over to using "indicators" and got rid of the systray. You would have to go into the dconf-editor (as James states) to add things to the whitelist. Now, in Oneiric, there is a package called sni-qt that turns all systray icons into indicator icons, for use with unity. It is installed by default on a fresh install, but apparently not in an upgrade.

If you have UIM (or any other systray app) installed but can't see the icon, installing the sni-qt package and logging out/in again will generally give you the icon in the unity panel.

  • Thanks, but I did a clean install, since I was using Maverick before, so sni-qt was already installed. Still no dice with getting the UIM icon that way. Doesn't sni-qt only work with Qt applications? There are two Qt toolbars: uim-toolbar-qt and uim-toolbar-qt4, but both of them are free-floating toolbars rather than systray icons. – James Nov 22 '11 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.