1

I am new with Linux. I've been experimenting with Ubuntu and Kali Linux and decided to install Conky. I ran the following commands:

sudo apt-get install conky
sudo apt-get install conky-manager

But then I found a website that recommended conky curl beacause it's easier to manage and better looking. I decided to follow up with new commands:

sudo apt-get install conky curl
cd && wget -O .elune-eos-bauraturia-conky.sh http://drive.noobslab.com/data/conky/eos-elune-bauraturia/elune-eos-bauraturia-conky.sh
cd && chmod +x .elune-eos-bauraturia-conky.sh && ./.elune-eos-bauraturia-conky.sh

Now conky is not running... Here is what appears in terminal when I try to run it:

conky: Syntax error (/root/.conkyrc:2: '=' expected near 'yes') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: desktop window (a00015) is subwindow of root window (25d)
conky: window type - override
conky: drawing to created window (0xe00001)
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  92
  Current serial number in output stream:  96

Any help will be appreciated. Thanks!

Edit: my .conkyrc file: https://paste.ubuntu.com/20310549/

  • 1
    You're aware that conky and curl are separate programs, yes? – wjandrea Jul 20 '16 at 21:08
  • No, I didn't know that, but something happened that messed up the conky file after I Installed conky-curl. – BeastPR Jul 20 '16 at 21:35
  • 3
    It appears that there may be a syntax error in your .conkyrc file. If you post that, it might help diagnosis. – Organic Marble Jul 20 '16 at 21:53
  • 3
    @BeastPR Don't put it in the comment box! Comments don't support advanced formatting or even line breaks, which would make it impossible to read. Put it on a pastebin site like paste.ubuntu.com – wjandrea Jul 20 '16 at 22:25
  • 1
    It is often a better experience to start with a bare conky and empty conf file and build up from there... – andrew.46 Jul 21 '16 at 4:27
1

The config file syntax has changed from Conky 1.10 version onwards.

The new config file uses Lua syntax.

More about Configuration File Syntax, Configuration Settings and Configuration Variables can be found in the below links:

| improve this answer | |
0

Try to remove the installation of conky first by running this command: sudo apt-get --purge remove conky conky-all. Then reinstall Conky using the following commands one at a time

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager

It's pretty straight forward and easy to install. After that, reboot your machine and Conky should be installed.

If you get stuck please use the following link http://www.teejeetech.in/p/conky-manager.html

| improve this answer | |
  • I followed your instructions but it didn't work. I keep having problems trying to run conky. Thanks for your help. – BeastPR Jul 20 '16 at 21:27
  • root@TheBeast:~# conky conky: Syntax error (/root/.conkyrc:2: '=' expected near 'yes') while reading config file. conky: Assuming it's in old syntax and attempting conversion. conky: desktop window (a00015) is subwindow of root window (25d) conky: window type - override conky: drawing to created window (0xe00001) X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 1 (X_CreateWindow) Serial number of failed request: 65 Current serial number in output stream: 69 – BeastPR Jul 20 '16 at 21:32
  • Did you try to remove the currently installation of conky you installed? Also you mentioned you had conky curl - installed and if this is in fact the case you will need to change the command – Rob Goss Jul 20 '16 at 21:38
  • Yes I tried to remove it with sudo apt-get --purge remove conky conky-all. What command should I use? – BeastPR Jul 20 '16 at 21:45
  • Conky Manager is working. I will continue running conky through conky manager. Thanks for your help. – BeastPR Jul 20 '16 at 22:10
0
own_window_type = "override"

replace to:

own_window_type = "normal"

or to:

own_window_type = "desktop"

Explanation: The issue you have is because you probably don't have nvidia-smi installed If you have a nvidia gpu you can install that. If you don't then you won't be able to use the Gpu widget and need to remove it in lua file. Run gdb conky. Run (gdb) run -c ~/.conkyrc. When it crashes, run (gdb) bt full. If you will notice the line that says sh: nvidia-smi: command not found then you need to install nvidia-smi.

Additionally you can set

double_buffer = false, 

instead of true value.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.