1

I'm running a relatively new Dell XPS with 14.04 LTS. Everything had been working fine and I've done several updates. Last night I used the Software Updater and installed a number of updates, after which I could not connect to any wifi networks.

When I run ifconfig, it returns only lo and eth1. Previously, it would also have returned wlan0.

I've also run:

$ lspci -nn | grep 0280

Which returns:

3a:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)

I can connect via ethernet, but really need to get the wifi up and running again.

This answers seems to suggest an offline solution: Install Intel AC 8260 wireless drivers offline

But I'm wondering if there is a more efficient solution while I'm connected via ethernet?

EDIT/UPDATE:

Per @Pilot6 request, I'm adding the output of dkms status below:

btusb-iwlwifi-intel8260, 1.7, 3.19.0-33-generic, x86_64: installed
btusb-iwlwifi-intel8260, 1.7, 3.19.0-64-generic, x86_64: installed
btusb-iwlwifi-intel8260, 1.7, 3.19.0-65-generic, x86_64: installed
intel-hid, 2.0, 3.19.0-33-generic, x86_64: installed
intel-hid, 2.0, 3.19.0-64-generic, x86_64: installed
intel-hid, 2.0, 3.19.0-65-generic, x86_64: installed
oem-audio-hda-daily-lts-vivid, 0.201512022217~ubuntu14.04.1, 3.19.0-33-generic, x86_64: installed
oem-audio-hda-daily-lts-vivid, 0.201512022217~ubuntu14.04.1, 3.19.0-64-generic, x86_64: installed
oem-audio-hda-daily-lts-vivid, 0.201512022217~ubuntu14.04.1, 3.19.0-65-generic, x86_64: installed
realtek-rts-cr, 1.4.3oem2, 3.19.0-33-generic, x86_64: installed
realtek-rts-cr, 1.4.3oem2, 3.19.0-64-generic, x86_64: installed
realtek-rts-cr, 1.4.3oem2, 3.19.0-65-generic, x86_64: installed
synaptic-i2c-hid-3.13.0-32-backport, 1.6.4: added
  • 1
    There was a case where disabling secure boot helped for iwlwifi too, but I can't get the reason. – Pilot6 Jul 20 '16 at 20:31
  • Please tell us the result of this terminal command: sudo modprobe iwlwifi If you get "Required key not available" then @Pilot6 is quite correct. Disable Secure Boot. – chili555 Jul 20 '16 at 20:34
  • @chili555 Do you have any idea why an in-tree module may require Secure boot disabled? – Pilot6 Jul 20 '16 at 20:35
  • @chili555: the result of sudo modprobe iwlwifi is modprobe: ERROR: could not insert 'iwlwifi': Required key not available - sorry - meant to add that I'm about to try the suggestion... – outsideshot Jul 20 '16 at 20:46
  • 1
    @outsideshot Please edit your question and add output of dkms status terminal command. – Pilot6 Jul 21 '16 at 10:30
1

modprobe: ERROR: could not insert 'iwlwifi': Required key not available

This is a new issue in Ubuntu. I suggest that you register and file a bug report: https://help.ubuntu.com/community/ReportingBugs

It appears that the only solution so far is to enter the computer's BIOS and turn off Secure Boot.

To do so, look around the options after booting your computer in the setup utility mode; look for a Secure Boot switch and turn it off. Then exit and boot Ubuntu normally

Secure Boot is a security standard developed by the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer

Reboot. Your wireless should now be working.

  • I have a 7260 AC adapter with Secure Boot enabled and I do not have this problem on Xenial. – Pilot6 Jul 21 '16 at 6:28
  • @Pilot6 It seems that somebody made a dkms package from backports to support some newer Intel chipsets, it is named btusb-iwlwifi-intel8260. A few users on ubuntuforums must have used it for a 8260 chipset with a subsystem ID of 0050 – Jeremy31 Jul 21 '16 at 10:27
  • That makes sense. We need to check it. – Pilot6 Jul 21 '16 at 10:28
0

You can upgrade the kernel and firmware by one command:

sudo apt-get install linux-generic-lts-xenial linux-firmware

if you are connected to internet.

Besides that you need to update the kernel to support Intel 8260 adapter, you need to remove a custom btusb-iwlwifi-intel8260 module that you installed to support 8260 on older kernels.

Remove it by

sudo dkms remove btusb-iwlwifi-intel8260/1.7 --all

With installed the 4.4 (xenial) kernel the Intel 8260 should work out of the box with Secure Boot enabled.

  • Am I correct that this will only be effective if I upgrade my kernel to 4.4? Currently I'm running 3.19 (per uname -a which returns 3.19.0-65-generic #73~14.04.1-Ubuntu SMP Wed Jun 29 21:05:22 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux. – outsideshot Jul 22 '16 at 1:20
  • You installed a custom kernel module that supports the 8260 adapter on kernel 3.19. That is why you need to disable Secure Boot. Kernel 4.4 supports this adapter natively. – Pilot6 Jul 22 '16 at 8:49
  • Sorry for the delayed reply - I'm hesitant to upgrade my kernel now that everything seems to be working and stable. But I really appreciate the suggestion. I'm going to do a little more research on this front but I will upvote your answer anyway. – outsideshot Jul 23 '16 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.