1

I never had any problems with Ubuntu for 2 years, but my WiFi randomly stopped working today.

I have Ubuntu 14.04 installed alongside Windows 10, and WiFi works on my Windows partition so I know it's not a hardware issue.

I tried navigating to System Settings -> Software & Updates -> Additional Drivers and I am able to see my Broadcom driver but it says "This device is not working."

Could someone please direct me how to fix this issue?

Thanks for your time.

EDIT: My output of lspci -knn | grep Net -A2 is:

01:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
Subsystem: Lenovo Device [17aa:0623]
6
  • Disable Secure Boot in BIOS. With new kernels it does not let to load 3rd party drivers.
    – Pilot6
    Commented Jul 20, 2016 at 14:36
  • I have Secure Boot disabled and it is still not working. Commented Jul 20, 2016 at 14:40
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command.
    – Pilot6
    Commented Jul 20, 2016 at 14:43
  • I have added the output. Commented Jul 20, 2016 at 14:47
  • the driver is not installed. Re-install it by sudo apt-get install --reinstall bcmwl-kernel-source.
    – Pilot6
    Commented Jul 20, 2016 at 14:48

0

You must log in to answer this question.

Browse other questions tagged .