0

after setting up apache and everything working correctly i tried to go to localhost/phpmyadmin and now instead of showing me the login page it's showing me this weird stuff: here is one line of it. it's a huge pile of code.

addJSON( 'list', PMA_RecentFavoriteTable::getInstance('recent')->getHtmlList() ); exit; } if ($GLOBALS['PMA_Config']->isGitRevision()) { if (isset($_REQUEST['git_revision']) && $GLOBALS['is_ajax_request'] == true) { PMA_printGitRevision(); exit; } echo '

and then below that php myadmin demo server with more pile of code..

7
  • Looks like apache php module is not installed. Try installing libapache2-mod-php5 and reload/restart apache service
    – aneeshep
    Jul 20 '16 at 10:40
  • hey thanks for replying terminal says that libapache2-mod-php5' has no installation candidate
    – flex_
    Jul 20 '16 at 10:42
  • also i have php7 idk if that helps
    – flex_
    Jul 20 '16 at 10:43
  • Can you provide some more details?. OS , PHP, Apache version. and the steps you followed to install apache, php and phpmyadmin. I will try to replicate the same in my local env
    – aneeshep
    Jul 20 '16 at 14:09
  • @aneeshep ubuntu 16.04. the steps were from digitalocean how to install LAMP.
    – flex_
    Jul 20 '16 at 18:53
0

Installing libapache2-mod-php should fix it.


Then, you can purge your installation and, if you want a simple installer which rarely fails, use the script provided by apachefriends. https://www.apachefriends.org/index.html

3
  • 1
    i have it installed bro.
    – flex_
    Jul 20 '16 at 11:20
  • @theprogrammer: According to your comments, you didn't have it installed initially when you wrote the question. Jul 20 '16 at 11:23
  • i checked it out after the first guy commeted. i tried again now and it said it's installed
    – flex_
    Jul 20 '16 at 11:24
0

add this to apache2.conf:

<Directory /usr/share/phpMyAdmin/>
        Options FollowSymLinks
        php_flag engine on
        Require all granted
</Directory>

Not the answer you're looking for? Browse other questions tagged or ask your own question.