2

I got a recurrent error

Setting up plexmediaserver (1.0.0.2261-a17e99e) ...
OK
Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
Job for plexmediaserver.service failed because the control process exited with error code. See "systemctl status plexmediaserver.service" and "journalctl -xe" for details.
dpkg: error processing package plexmediaserver (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 plexmediaserver
E: Sub-process /usr/bin/dpkg returned an error code (1)

then systemctl status plexmediaserver.service gives

● plexmediaserver.service - Plex Media Server for Linux
   Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/plexmediaserver.service.d
           └─overide.conf
   Active: inactive (dead) (Result: exit-code) since Wed 2016-07-20 17:49:09 HKT; 2min 36s ago
  Process: 5531 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/m

Jul 20 17:49:04 homeserver systemd[1]: plexmediaserver.service: Unit entered failed state.
Jul 20 17:49:04 homeserver systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Jul 20 17:49:09 homeserver systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Jul 20 17:49:09 homeserver systemd[1]: Stopped Plex Media Server for Linux.
Jul 20 17:49:09 homeserver systemd[1]: plexmediaserver.service: Start request repeated too quickly.
Jul 20 17:49:09 homeserver systemd[1]: Failed to start Plex Media Server for Linux.

I already tried different way to purge the previous install, nothing works. For info, the route that lead me here : - See on plex web app that there is an update available, connect by SSH to my server , wget the deb file, then dpkg-i => failure - I then decide de finally do the ubuntu 16.04 upgrade. - after upgrade, still not working for the upgrade - tried de-install, then re-install, no luck, try again with purge, still no luck.

  • askubuntu.com/questions/614232/… ? – Rinzwind Jul 20 '16 at 9:59
  • create dir and chmod, no problem, then for the 2 following commands, it gives respectively Failed to reset failed state of unit plexmediaserver.service: Unit plexmediaserver.service is not loaded. and Failed to start plexmediaserver.service: Unit plexmediaserver.service not found. – Memes Jul 20 '16 at 10:04
  • scratch that, it was purged... I reinstalled it, got same error, while installing, then ran the code, first one ran properly (no output), the last line give me again Job for plexmediaserver.service failed because the control process exited with error code. See "systemctl status plexmediaserver.service" and "journalctl -xe" for details. – Memes Jul 20 '16 at 10:10
1

it ended up being a permission issue. so a

sudo chmod 0777 -R /var/lib/plexmediaserver
sudo chown plex:plex -R /var/lib/plexmediaserver
sudo service plexmediaserver restart

solved the issue

It appears as well that the sudo apt-get remove --purge plexmediaserver does not clean all things.

| improve this answer | |
  • 1
    Please don't forget to mark your own post as the answer :) – You'reAGitForNotUsingGit Jul 20 '16 at 13:02
  • yes, needs to wait 2 days to do so :) – Memes Jul 21 '16 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.