0

I'm using Ubuntu 16.04 on a live USB, under a intel NUC. I've used YUMI for creating the live USB and I have other SO's as lives on the USB.

When I boot the USB, I get a pop up error, that says initramfs-tools 0.122ubuntu8.1 has problems. When I try to upgrade I get the following error

Removing plymouth-theme-ubuntu-text (0.9.2-3ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
cp: cannot create regular file '/cdrom/casper/initrd.gz.new': No such file or directory
dpkg: error processing package plymouth-theme-ubuntu-text (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 plymouth-theme-ubuntu-text
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I try to apt-get -f install:

root@ubuntu:/home/ubuntu# sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gir1.2-rb-3.0 gir1.2-secret-1 gir1.2-udisks-2.0 gnome-video-effects
  guile-2.0-libs libandroid-properties1 libdmapsharing-3.0-2 libevent-2.0-5
  libgc1c2 libgpod-common libgpod4 libnatpmp1 liboxideqt-qmlplugin
  liboxideqtcore0 liboxideqtquick0 libqqwing2v5 libqt5positioning5
  librhythmbox-core9 libsgutils2-2 media-player-info oxideqt-codecs
  python3-brlapi python3-louis python3-mako python3-pyatspi python3-speechd
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-ubuntu-onlineaccounts qml-module-ubuntu-web
  qtdeclarative5-accounts-plugin qtdeclarative5-qtquick2-plugin rhythmbox-data
  signon-keyring-extension syslinux syslinux-common syslinux-legacy
  transmission-common unity-webapps-qml usb-creator-common xbrlapi
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  plymouth-theme-ubuntu-text
0 upgraded, 0 newly installed, 1 to remove and 335 not upgraded.
12 not fully installed or removed.
After this operation, 53.2 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 218095 files and directories currently installed.)
Removing plymouth-theme-ubuntu-text (0.9.2-3ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
cp: cannot create regular file '/cdrom/casper/initrd.gz.new': No such file or directory
dpkg: error processing package plymouth-theme-ubuntu-text (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 plymouth-theme-ubuntu-text
E: Sub-process /usr/bin/dpkg returned an error code (1)

Autoremove does not fix anything either. No dependencies problem, so all the askubuntu question I've found does not fix my problem. I've found this link on launchpad https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1278330

When I try to remove it

root@ubuntu:/home/ubuntu# apt-get remove --purge plymouth-theme-ubuntu-text
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gir1.2-rb-3.0 gir1.2-secret-1 gir1.2-udisks-2.0 gnome-video-effects
  guile-2.0-libs libandroid-properties1 libdmapsharing-3.0-2 libevent-2.0-5
  libgc1c2 libgpod-common libgpod4 libnatpmp1 liboxideqt-qmlplugin
  liboxideqtcore0 liboxideqtquick0 libqqwing2v5 libqt5positioning5
  librhythmbox-core9 libsgutils2-2 media-player-info oxideqt-codecs
  python3-brlapi python3-louis python3-mako python3-pyatspi python3-speechd
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-ubuntu-onlineaccounts qml-module-ubuntu-web
  qtdeclarative5-accounts-plugin qtdeclarative5-qtquick2-plugin rhythmbox-data
  signon-keyring-extension syslinux syslinux-common syslinux-legacy
  transmission-common unity-webapps-qml usb-creator-common xbrlapi
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  plymouth-theme-ubuntu-text*
0 upgraded, 0 newly installed, 1 to remove and 335 not upgraded.
12 not fully installed or removed.
After this operation, 53.2 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 218100 files and directories currently installed.)
Removing plymouth-theme-ubuntu-text (0.9.2-3ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
cp: cannot create regular file '/cdrom/casper/initrd.gz.new': No such file or directory
dpkg: error processing package plymouth-theme-ubuntu-text (--purge):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 plymouth-theme-ubuntu-text
E: Sub-process /usr/bin/dpkg returned an error code (1)

And reinstall

root@ubuntu:/home/ubuntu# sudo apt-get install plymouth-theme-ubuntu-text
Reading package lists... Done
Building dependency tree       
Reading state information... Done
plymouth-theme-ubuntu-text is already the newest version (0.9.2-3ubuntu13.1).
The following packages were automatically installed and are no longer required:
  gir1.2-rb-3.0 gir1.2-secret-1 gir1.2-udisks-2.0 gnome-video-effects
  guile-2.0-libs libandroid-properties1 libdmapsharing-3.0-2 libevent-2.0-5
  libgc1c2 libgpod-common libgpod4 libnatpmp1 liboxideqt-qmlplugin
  liboxideqtcore0 liboxideqtquick0 libqqwing2v5 libqt5positioning5
  librhythmbox-core9 libsgutils2-2 media-player-info oxideqt-codecs
  python3-brlapi python3-louis python3-mako python3-pyatspi python3-speechd
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-ubuntu-onlineaccounts qml-module-ubuntu-web
  qtdeclarative5-accounts-plugin qtdeclarative5-qtquick2-plugin rhythmbox-data
  signon-keyring-extension syslinux syslinux-common syslinux-legacy
  transmission-common unity-webapps-qml usb-creator-common xbrlapi
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 335 not upgraded.
12 not fully installed or removed.
Need to get 0 B/9,078 B of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up initramfs-tools (0.122ubuntu8) ...
update-initramfs: deferring update (trigger activated)
cp: cannot create regular file '/cdrom/casper/initrd.gz.new': No such file or directory
dpkg: error processing package initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools | dracut; however:
  Package initramfs-tools is not configured yet.
  Package dracut is not installed.

dpkg: error processing package plymouth (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing package plymouth-theme-ubuntu-text (--configure):
 package plymouth-theme-ubuntu-text is not ready for configuration
 cannot configure (current status 'half-installed')
No apport report written because the error message indicates its a followup error from a previous failure.`
` dpkg: dependency problems prevent configuration of linux-image-4.4.0-31-generic:
 linux-image-4.4.0-31-generic depends on initramfs-tools | linux-initramfs-tool; however:
  Package initramfs-tools is not configured yet.
  Package linux-initramfs-tool is not installed.
  Package initramfs-tools which provides linux-initramfs-tool is not configured yet.

dpkg: error processing package linux-image-4.4.0-31-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-4.4.0-31-generic:
 linux-image-extra-4.4.0-31-generic depends on linux-image-4.4.0-31-generic; however:
  Package linux-image-4.4.0-31-generic is not configured yet.

dpkg: error processing package linux-image-extra-4.4.0-31-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-4.4.0-31-generic; however:
  Package linux-image-4.4.0-31No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
-generic is not configured yet.
linux-image-generic depends on linux-image-extra-4.4.0-31-generic; however:
Package linux-image-extra-4.4.0-31-generic is not configured yet.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 4.4.0.31.33); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-image-4.4.0-31-generic:
 linux-signed-image-4.4.0-31-generic depends on linux-image-4.4.0-31-generic (= 4.4.0-31.50); however:
  Package linux-image-4.4.0-31-generic is not configured yet.

dpkg: error processing package linux-signed-image-4.4.0-31-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configurNo apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
ation of linux-signed-image-generic:
 linux-signed-image-generic depends on linux-signed-image-4.4.0-31-generic; however:
  Package linux-signed-image-4.4.0-31-generic is not configured yet.
 linux-signed-image-generic depends on linux-image-extra-4.4.0-31-generic; however:
  Package linux-image-extra-4.4.0-31-generic is not configured yet.

dpkg: error processing package linux-signed-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-generic:
 linux-signed-generic depends on linux-signed-image-generic (= 4.4.0.31.33); however:
  Package linux-signed-image-generic is not configured yet.

dpkg: error processing package linux-signed-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-label:
 plymouth-label depends on plymouth (= 0.9.2-3ubuntu13.1); however:
  Package plymouth is not configured yet.

dpkg: error processing package plymoNo apport report written because MaxReports is reached already
                  No apport report written because MaxReports is reached already
                                                                               uth-label (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plymouth-theme-ubuntu-logo:
 plymouth-theme-ubuntu-logo depends on plymouth (= 0.9.2-3ubuntu13.1); however:
  Package plymouth is not configured yet.
 plymouth-theme-ubuntu-logo depends on plymouth-label (= 0.9.2-3ubuntu13.1); however:
  Package plymouth-label is not configured yet.

dpkg: error processing package plymouth-theme-ubuntu-logo (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 initramfs-tools
 plymouth
 plymouth-theme-ubuntu-text
 linux-image-4.4.0-31-generic
 linux-image-extra-4.4.0-31-generic
 linux-image-generic
 linux-generic
 linux-signed-image-4.4.0-31-generic
 linux-signed-image-generic
 linux-signed-generic
 plymouth-label
 plymouth-theme-ubuntu-logo
E: Sub-process /usr/bin/dpkg returned an error code (1)

Do anyone know any fix for this?

Thanks in advance

R.

2

After a month of research I've found why I got the errors.

I was running Ubuntu on a Live state, where after running apt-get upgrade, my kernel got upgraded, with the result of the above errors. To fix the error and enable the installation of files again, I did the following THIS CAN MAKE THE SYSTEM UNUNSABLE.

  1. mkinitramfs - u : this will create an initramps img.
  2. update-initramfs - u : update the img
  3. Now run which update-initramfs to find the config file that is giving us the error
  4. Add an exit to the config file so you will not get the error code. In my case, on the line 3 I just added exit 0.
  5. apt-get -f install

With a bit of luck the kernel wont crush and the issue will get fixed. If not, your system died, sorry. This is not a solution, we are only adding an exit to the script so we wont get promped to the error and we be able to install packages.

Conclusion: Do not never ever upgrade a live system unless you know what are you doing. Kernel is so delicate.

0

Try to:

  1. Run again $ apt-get remove --purge plymouth-theme-ubuntu-text
  2. $ whereis plymouth-theme-ubuntu-text
  3. Manually remove everything you find related to it
  4. Reinstall plymouth-theme-ubuntu-text

Let me know if it works for you, it worked for me in a different case

  • I only get the following output: root@ubuntu:/home/ubuntu# whereis plymouth-theme-ubuntu-text plymouth-theme-ubuntu-text: – kek Jul 20 '16 at 11:20
  • that is good, it means it was totally removed and it should leave the environment for a fresh install without any errors; it is kind of weird that the error persists. Unfortunately I do not know how to help you from here on, but I would advise you to see more documentation and if what you want to install depends on other packages that need to be install before it. Good luck with solving the problem - Hellas – Hellas Jul 20 '16 at 13:13
  • I tried to reinstall it again, but Im still getting other output errors similar to the main question ones. – kek Jul 20 '16 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.